1 系统介绍 - TestCenter5.5帮助文档

1 系统介绍


1.1 系统简介 - TestCenter5.5帮助文档

1.1 系统简介

TestCenter（简称TC）是面向测试流程的测试生命周期管理工具，符合TMMI标准的测试流程，可迅速建立完善的测试体系，规范测试流程，提高测试效率与质量，实现对测试的过程管理，提高测试工程的生产力。TC是上海泽众软件科技有限公司自主研发的一款强大的测试管理工具，基于B/S体系结构，可以分别通过自动化测试或者手工测试制定测试流程，并且提供多任务的测试执行，以及缺陷跟踪管理系统，最终生成测试报表。TestCenter可以和本公司的测试工具AutoRunner、Terminal AutoRunner系列集成，也可以和其他测试工具集成，提供强大的自动化功能测试。

TestCenter面向的用户是所有需要提高软件开发质量的软件公司、软件外部企业，以及提供测试服务的部门。使用TestCenter，可以帮助用户明确测试目标、测试需求并建立完善的测试计划；可以帮助用户掌控测试过程并建立有效地质量控制点；可以帮助用户严谨地实施测试计划并对测试全过程进行针对性评估。


1.2 功能介绍 - TestCenter5.5帮助文档

1.2 功能介绍

测试项目管理

支持项目的团队管理；支持字段属性自定义。新版本新增了报文配置、工作周报、报工审批等功能，可以统筹管理整个测试项目。

测试计划管理

支持测试计划管理、多次执行手工测试和自动化测试；测试需求范围定义、测试集定义；数据模版的导入和导出。

测试需求管理

支持测试需求管理、支持测试需求树，树的每个节点是一个具体的需求，也可以定义子节点作为子需求。每个需求节点都可以关联到一个或者多个测试用例。根据需求可以创建相同名称的测试用例组；也可以通过需求向导创建关联一个或者多个测试用例的测试集。

测试业务组件管理

支持测试用例与业务组件之间的关系管理，通过测试业务组件和数据“搭建”测试用例，实现了测试用例的高度可配置和可维护性。主要是添加自动测试执行时所需要的脚本（通过AutoRunner或者Tar测试工具录制），同时也支持测试人员根据需求编写不同的脚本。

标准化测试用例库构建

支持测试用例的各种状态：通过、未执行、失败；支持手工编写测试用例、用例附件批量导入；支持执行中的测试用例管理；保证测试用例的质量，实现测试用例的标准化，降低了测试用例对个人的依赖。

用户角色管理

主要功能是：添加、删除、修改角色信息，并且可以模拟实际场景中的不同角色（主要体现在自动运行中），当角色绑定用例后，系统会根据不同的角色查找并执行不同的用例。

系统设置管理

用户管理（添加、删除用户），项目管理（查看TestCenter中包含的所有项目以及项目详细信息），自定义字段管理（添加自定义字段后体现在缺陷管理中），系统权限管理（为不同的角色设置不同的权限），邮件配置（配置邮件发送服务器，在缺陷管理中修改缺陷的状态，就可以通过自动发送邮件的形式发送给相关人员），登陆历史（记录用户登录和退出系统的信息）。

测试执行管理

支持测试自动执行（通过调用测试工具）；支持手工执行（手工操作的方式执行用例，来验证需求。错误时可以直接提交bug）。在测试计划发起手工测试成功后会显示在“手工测试”标签页中（测试计划中包含测试集，测试集中必须包含用例），点击运行名称进入详细信息界面首先分配角色（给相关测试人员）并执行测试用例，当执行测试用例失败后提交bug到缺陷管理中。当所有用例执行结束后会自动转移到手工日志中。在自动化测试执行之前，需要打开两个程序tnameserv.ext和TestAgent.exe。可以在测试集中发动自动化测试执行，也可以在测试计划中发动自动化测试执行，同时还可以查看自动化运行的详细信息。

日志报表与测试分析

支持手工测试日志，以测试用例为单位来保存测试日志；支持自动测试日志，支持步骤，截图和校验规则结果；支持每次测试的测试报告，支持用户自定义报表，支持多种统计图标，如需求覆盖率图、测试用例完成的比例分析图、业务组件覆盖比例图等；支持自动化测试的测试分析报告与手工测试的测试分析报告。

缺陷管理

支持从测试错误到曲线的自动添加与手工添加；支持自定义错误状态、自定义工作流的缺陷管理过程。报告提交测试人员发现的bug并可以使用过滤器和添加搜索条件的方式查询所需要的bug。显示当前所有提交Bug的状态（待确认、已分配、已完成等），同时统计报表中可以统计当前所有不同状态bug的数量以及所在模块的分布图。


1.3 服务支持 - TestCenter5.5帮助文档

1.3 服务支持

我们通过在线QQ、微信、电话、电子邮件为您提供支持与服务，您也可访问我们的网站http://www.spasvo.com/寻求帮助；为保证服务质量，确保有效地解决用户的问题，保障用户的项目实施进度，技术支持仅向授权用户和授权试用用户提供。请您在联系泽众技术支持时，告知您的单位名称和服务代码。

技术支持
    电话：021-60725088-8007

传真：021-60725088-8017
    电子邮件：support@spasvo.com

QQ：1404189128

泽众微信公众号

产品服务

有关培训、产品购买及试用授权方法的问题，请与销售代表联系，或联系泽　众咨询热线。

电话：021-60725088-8006

传真：021-60725088-8017

电子邮件: sales@spasvo.com


2 环境配置 - TestCenter5.5帮助文档

2 环境配置


2.1 硬件环境 - TestCenter5.5帮助文档

2.1 硬件环境

Pentium 2.4GHz CPU

2G Memory

至少5G的硬盘空间


2.2 软件环境 - TestCenter5.5帮助文档

2.2 软件环境

支持的操作系统：

windows xp/windows2000/windows2003/windows2008/windows vista/windows7

推荐的操作系统：

Windows xp/window2003/windows7

JDK1.7以上版本

IE6.0以上的浏览器

系统的分辨率，建议使用1024*768


3 安装说明 - TestCenter5.5帮助文档

3 安装说明

下面子章节详细介绍了TestCenter的安装与配置说明，以及在自动化测试流程中需要使用的AutoRunner、TestAgent安装配置详情。


3.1 TestCenter安装说明 - TestCenter5.5帮助文档

3.1 TestCenter安装说明


3.1.1 安装JDK（2017年9月20日前安装包需要此步骤） - TestCenter5.5帮助文档

3.1.1 安装JDK（2017年9月20日前安装包需要此步骤）

1.安装32位JDK 1.7，双击运行点击下一步直接到完成安装。


3.1.2 配置环境变量（2017年9月20日前安装包需要此步骤） - TestCenter5.5帮助文档

3.1.2 配置环境变量（2017年9月20日前安装包需要此步骤）

JDK配置的方法如下：

1) 右键点击我的电脑“属性”，选择“高级”。

2) 点击环境变量。

3) 在（Administrator）的用户变量中新建变量。

Ø 变量名：JAVA_HOME

Ø 变量值：C:\Program Files\Java\jdk1.7.0_79 即JDK所安装的路径

Ø 变量名: PATH

Ø 变量值：%JAVA_HOME%\bin *加入，不是覆盖。

Ø 变量名：CLASSPATH

Ø 变量值：.;%JAVA_HOME%\lib *注意前面还有一个“.;”

（以上C:\Program Files\Java\jdk1.7.0_79只是举一个例子，用户要根据自己所安装JDK的路径来配置。）

如下图：


3.1.3 安装TestCenter - TestCenter5.5帮助文档

3.1.3 安装TestCenter

建议TestCenter的安装服务器做到专机专用，避免数据和性能上的问题。

若安装服务器已存在MYSQL服务，安装之前先停止MYSQL服务，且需要保证MYSQL服务的名称不能是spasvoDBServer。

点击TestCenter5.5的安装图标进入下一界面，点击下一步直至安装完成即可。

注意：已经装有MYSQL数据库、存在MYSQL服务的情况下，安装程序将会根据用户的选择来安装。

a) 安装TestCenter MYSQL

1) 可能出现TestCenter数据库服务无法启动。

2) 可能出现TestCenter数据库脚本无法正常导入。

3) 可能出现TestCenter数据库脚本导入原有MYSQL数据库，覆盖原有"testcenter"数据库，造成数据丢失。

4) 可能导致无法启动TestCenter

b) 不安装TestCenter MYSQL

1) 程序将不安装数据库，不会对原有数据库造成任何影响。

2) TestCenter支持MYSQL5.5以上版本MYSQL服务。用户可以选择使用自身的MYSQL数据库。

3) 请专业数据库人员在安装目录下导入testcenter.sql文件至数据库中。

具体操作参考 8.2.5章节中的基库导入操作。


3.1.4 安装Flash - TestCenter5.5帮助文档

3.1.4 安装Flash

下载最新版Flash安装包双击安装完成即可。

参考网站：

https://helpx.adobe.com/flash-player/kb/installation-problems-flash-player-windows.html


3.1.5 申请license - TestCenter5.5帮助文档

3.1.5 申请license

先点击启动TestCenter图标，打开Tomcat服务器。然后在浏览器上访问http://localhost:8080/TestLab/Admin.swf登录管理员账号（admin 111111），点击许可证，选择申请许可证，弹出申请许可证对话框，选择需要申请的类型，使用的时长，以及同时在线人数，点击确定按钮，即可导出license。

若系统已过期，提示 “服务连接失败，请重新登录”，不能登陆后台的情况下，可以直接访问:

http://localhost:8080/TCLicence/TCLicence.html登录管理员账号（admin 111111）进行license申请。

将导出的testcentet.req文件通过e-mail发送到 support@spasvo.com邮箱申请


3.1.6 导入license - TestCenter5.5帮助文档

3.1.6 导入license

1、登录进后台管理系统http://localhost:8080/TestLab/Admin.swf后，导入许可证

与申请lic时一致，进入到许可证页面，选择导入许可证，将回复的lic文件导入到系统内，导入成功后，点击启动TestCenter，即可成功使用系统。

双击桌面“运行TestCenter”图标进入TestCenter。

2、或者在http://localhost:8080/TCLicence/TCLicence.html系统，导入许可证


3.1.7 TestCenter卸载说明 - TestCenter5.5帮助文档

3.1.7 TestCenter卸载说明

注意：卸载TestCenter时,程序会根据用户选择来卸载。

a) 卸载TestCenter MYSQL

1) 程序会完全删除TestCenter数据库及服务,包括里面的数据。

2) 程序不会删除用户原有的MYSQL数据库及服务,不会影响用户数据库中的数据。

b) 不卸载TestCenter MYSQL

程序会删除TestCenter程序体,不会删除TestCenter MYSQL数据库及服务，不会影响数据库中的数据。

PS：如果卸载过程中选择不删除数据库，在备份数据后，又需要删除数据库，请重新覆盖安装TestCenter后,执行卸载程序。

最终解释权归上海泽众软件有限公司。


3.2 TestCenter配置说明 - TestCenter5.5帮助文档

3.2 TestCenter配置说明

因为TestCenter需要通过TestAgent与AutoRunner集成来进行自动化测试的，所以在TestCenter安装完成之后，我们需要进行相应的配置来实现我们的自动化测试流程。

自动化测试执行完成后需要通过HTML报表查看用例执行总览，相应的还需要进行HTML报表的配置。


3.2.1 数据库配置（数据库的ip、端口、用户名或是密码需要修改时） - TestCenter5.5帮助文档

3.2.1 数据库配置（数据库的ip、端口、用户名或是密码需要修改时）

首先找到TC安装目录下的\TestCenter\tomcat7.0\webapps\TestLab\WEB-INF

找到 [image] 并用编辑软件打开进行修改即可（记事本即可）


3.2.2 HTML报表系统配置（HTML报表系统所在tomcat端口或IP发生变化时） - TestCenter5.5帮助文档

3.2.2 HTML报表系统配置（HTML报表系统所在tomcat端口或IP发生变化时）

1、 打开TC安装目录下的TestCenter\tomcat7.0\webapps\TestLab\com找到 [image] message.xml并用编辑软件打开，

配置<htmlserverip></htmlserverip>中的IP地址为html报表系统的ip和该系统运行的tomcat端口即可。

2、 编辑TC安装目录下的

\TestCenter\tomcat7.0\webapps\TestLabHtml\WEB-INF\classes下的db.properties


3.2.3 TestCenter测试环境配置 - TestCenter5.5帮助文档

3.2.3 TestCenter测试环境配置

a) 打开TC服务器D:\ 路径下publicFunction.bsh

b) 找到方法void setBaseinfoByServerId()，在方法的后面追加被测核心XP的IP、核心XP对应数据库IP、usetab，如下： else if("13".equals(serverId)){ databaseId = "10.189.146.131:1433/run"; --核心系统数据库信息

kcxpIp = "10.189.146.132"; --XP地址

usetab = "usedata_13"; --TestCenter缓存表表名

c) 打开数据库管理工具Navicat for Mysql，找到tx_pklistmemo表，在表中添加对应的被测核心信息

d) 在测试计划的轮次下发起对测试集中用例的执行器选择页面即可看到被测核心服务器的名称


3.2.4 TestCenter升级维护 - TestCenter5.5帮助文档

3.2.4 TestCenter升级维护

特别提醒：在升级前请一定记得备份备份备份！

1.TestCenter后台更新：

将相应的TestLaboXXXX.jar复制到TC安装目录下的

TestCenter\tomcat7.0\webapps\TestLab\WEB-INF\lib目录中，并删除该目录下的TestLaboXXXX.jar，最后删除\TestCenter\tomcat7.0\work\Catalina下的localhost文件夹。

2.TestCenter前台更新 ：

将软件升级包中的所有文件复制到TC安装目录下的

TestCenter\tomcat7.0\webapps\TestLab

目录中，最后删除\TestCenter\tomcat7.0\work\Catalina下的localhost文件夹。

3.HTML报表系统安装

将TestLabHtml.war文件复制到TC安装目录中的\TestCenter\tomcat7.0\webapps中即可。

4.HTML报表系统更新

将TestLabHtml.war替换到TC安装目录下的\TestCenter\tomcat7.0\webapps下，并删除TestLabHtml文件夹，最后删除\TestCenter\tomcat7.0\work\Catalina下的localhost文件夹。

5.配置公共脚本

将publicFunction.bsh复制到D:盘根目录下

PS:如果放置于其他位置，需每次修改业务组件中的脚本的source("D:\\publicFunction.bsh");为该脚本路径


3.2.5 AutoRunner安装 - TestCenter5.5帮助文档

3.2.5 AutoRunner安装

使用安装包按照安装提示安装即可。


3.2.6 TestAgent启动与配置 - TestCenter5.5帮助文档

3.2.6 TestAgent启动与配置

进行自动执行是需要借助TestAgent将AutoRunner与TestCenter进行连接实现联跑流程。所以自动执行前我们需要：

1) 启动TestAgent：点击StartAgent图标或者TestAgent根目录下的StartAgent.bat文件。

点击StartAgent图标：

点击TestAgent根目录下的StartAgent.bat文件：

2) 点击配置，每一个配置页面的服务器IP设置成登录TestCenter服务器的IP，分别进行保存设置（每一个配置页面都需要单独点击保存）。

3) 配置AutoRunner路径，找到安装路径中的

4) 打开TestAgent根目录，找到webar_c.bsh文件打开编辑，找到localArPath = "C:\\Program Files (x86)\\Spasvo\\AutoRunner";（其中=””中的路径为AutoRunner实际安装路径）

5) 配置完成后进入TestCenter服务器JDK的bin目录（例如C:\Program Files (x86)\Java\jdk1.7.0_79\bin）下开启Tnameserv服务。

6) 点击启动按钮，TestAgent加载执行器启动成功


4 新手上路 - TestCenter5.5帮助文档

4 新手上路


4.1 快速入门 - TestCenter5.5帮助文档

4.1 快速入门

首先我们按照章节3安装说明中成功安装了我们的TestCenter之后，我们就可以根据我们的快速入门进行一个操作使用了。TestCenter测试管理系统分为后台和前台界面，后台界面只允许管理员用户登录，管理员登陆系统的主要目的是创建用户和项目以及对系统的数据进行管理和掌控，本身并不参与测试流程管理；而对整个系统进行测试流程管理则是管理员创建的项目用户登录前台界面进行操作的。

此章节中的快速入门会以完整最简的案例流程来指导您操作使用TestCenter。

我们可以用管理员用户（admin，111111）登录TestCenter后台地址：http://localhost:8080/TestLab/Admin.swf

用后台创建的用户登录登录TestCenter前台地址：http://localhost:8080/TestLab


4.1.1 后台新建用户与项目 - TestCenter5.5帮助文档

4.1.1 后台新建用户与项目

登录TestCenter后台（http:localhost:8080/TestLab/Admin.swf）之后可以进行用户创建和项目管理。


4.1.1.1 用户管理 - TestCenter5.5帮助文档

4.1.1.1 用户管理

路径：

【用户管理】-【添加】

描述：

点击添加进行项目用户，新建的用户用于前台登录

截图：

步骤：

1. 点击添加按钮

2. 输入下列菜单中相应栏位值

栏位名称 | 描述 | 特殊要求
用户名 | 输入系统登录用户名 | 1.不能为空 2.不能重复
密码 | 设置系统用户登录密码 | 1.不能为空 2.至少输入6位
确认密码 | 确认输入的登录密码 | 1.不能为空 2.必须与密码保持一致
真实姓名 | 输入真实姓名 | 1.不能为空 2.支持重复
Email | 输入邮箱地址 | 1.不能为空 2.必须符合正确的邮箱格式
用户角色 | 选择用户角色 | 该角色只为默认角色，与项目中角色无关

3. 点击保存提示新增用户成功


4.1.1.2 项目管理 - TestCenter5.5帮助文档

4.1.1.2 项目管理

路径：

【项目管理】-【新增项目】

描述：

点击新增项目进行项目创建。前台的项目管理均以此为单位，所以要先创建项目。

截图：

步骤：

1. 点击新增项目按钮

2. 输入下列菜单中相应栏位值

栏位名称 | 描述 | 特殊要求
项目名称 | 输入项目名称 | 1.不能为空 2.不能重复
项目代码 | 设置项目代码 | 1.不能为空 2.不能重复
项目经理 | 选择项目经理,该项目经理拥有本项目在前台所有操作权限，首次需使用本项目经理登录并进行人员分配 | 1.不能为空 2.可以点》双击选择或者选中用户点击确定
测试计划开始时间 | 选择项目计划开始时间 | 1.不能为空 2.必须小于计划结束时间
测试计划结束时间 | 选择项目计划结束时间 | 1.不能为空 2.不早于计划开始时间

3. 点击保存提示新建项目成功

备注说明：

使用新建的项目经理用户登录前台地址：http://localhost:8080/TestLab，可以登录成功，并且项目选择工作台会显示新创建的项目。点击项目名称进入项目。


4.1.2 前台分配权限与团队管理 - TestCenter5.5帮助文档

4.1.2 前台分配权限与团队管理

新建项目经理用户登录前台地址：http://localhost:8080/TestLab


4.1.2.1 分配权限 - TestCenter5.5帮助文档

4.1.2.1 分配权限

路径： | 【TestCenter】-【系统设置】-【权限管理】
描述： | 进行默认权限的导入与分配，该功能是为了给项目其他用户分配权限，系统默认的角色包括测试员、测试负责人、开发负责人、开发工程师。
截图： |
步骤： | 1. 点击导入管理添加的默认权限，功能列表会显示默认的导入的角色权限信息。


4.1.2.2 团队管理 - TestCenter5.5帮助文档

4.1.2.2 团队管理

路径： | 【TestCenter】-【系统设置】-【项目管理】-【团队管理】
描述： | 进行项目的团队管理，项目经理负责将项目其他成员加入项目，分配权限，这样成员登录系统才可看到相关项目信息。
截图： |
步骤： | 1. 勾选未关联的用户（待加入项目的用户） 2. 选择项目角色 3. 勾选功能列表（用户权限） 4. 点击加入用户，即可成功添加。


4.1.3 自动化测试流程管理 - TestCenter5.5帮助文档

4.1.3 自动化测试流程管理

上面这个流程图是TestCenter自动化测试的一个大致流程，下面我们就根据流程图，以证券项目为例进行一个完整的自动化流程测试。

注：这里的流程是在新建项目与用户、分配权限和加入用户已经完成的基础上进行的前台项目流程的操作。如不清楚如何操作请具体查看4.1.1和4.1.2章节。


4.1.3.1 新建业务组件 - TestCenter5.5帮助文档

4.1.3.1 新建业务组件

业务组件是自动化测试的脚本依据，所以在之前需要先将测试用例脚本上传到TC，在测试用例里需要绑定相应的脚本组件。

路径：

【TestCenter】-【测试构建】-【业务组件】

描述：

进行业务组件的新建，对业务组件进行新增和维护等操作

截图：

步骤：

1. 点击新建组输入下列表格相应栏位

栏位名称 | 描述 | 特殊要求
名称 | 输入组件组名称 | 1. 不能为空 2. 不能重复
描述 | 输入组件组描述 |
是否连续添加 | 勾选是否连续添加按钮，可以连续添加多个组件组，此框不消失 |

2. 点击添加组件输入下列表格相应栏位

字段名称 | 描述 | 特殊要求
继承 | 可选择继承、不继承 | 1. 不能为空
运行环境 | 可选择autorunner连接跑自动化 | 1. 不能为空
继承组件 | 继承组件 |
组件名 | 输入组件名 | 1. 不能为空 2. 不能重复
组件版本 | 输入组件版本 |
详细描述 | 输入详细描述 |
脚本名 | 界面自动化测试，点击“导入脚本”按钮，选择三个文件：*.bsh,*.xls,*.xml | 可参考附件410411-委托买卖业务，导入三个文件
是否连续添加 | 可以连续添加组件 |

3. 点击确定新建组件成功

4. 点击脚本编辑页面对脚本进行相应修改保存


4.1.3.2 新建测试需求 - TestCenter5.5帮助文档

4.1.3.2 新建测试需求

测试需求是测试场景和测试用例的集合，可以把不同的场景和用例放在各自独立的测试需求中。

方法一：直接新建需求

路径：

【TestCenter】-【测试需求】-【测试需求】

描述：

点击进行测试需求的新建

截图：

步骤：

1. 点击添加子需求

2. 输入下列表格中相应栏位

栏位名称 | 描述 | 特殊要求
需求名 | 输入需求名称 | 1.不能为空 2.不能重复
RBT | 输入数字 | 1. 不能超过100 2. 不能为空
状态 | 下拉框选择需求状态 | 1.不能为空
优先级 | 下拉框选择需求优先级 | 1.不能为空
描述 | 输入描述 |
是否连续添加 | 勾选是否连续添加按钮，可以连续添加多个需求，此框不消失 |

3.点击确定新增需求成功

方法二：通过模板批量导入

路径： | 【TestCenter】-【测试需求】-【测试需求】
截图： |
步骤： | 1. 点击导入模板配置 2. 点击选择属性，输入对应列 3. 点击添加，属性列会显示相应的属性 4. 输入目录分隔符输入/，输入起始行（因为一般第1行为列名，从第2行开始），输入起始页、结束页（实际填的值根据导入的Excel文件的页数决定） 5. 点击保存提示模板保存成功 6. 根据上面配置的模板属性去建需要导入的Excel文件，列名与模板中配置的属性列保持一致，如下图： 7. Excel文件配置成功后点击需求导入，提示导入成功，展开默认需求节点显示导入成功的需求信息


4.1.3.3 新建需求场景 - TestCenter5.5帮助文档

4.1.3.3 新建需求场景

需求中的用例场景是测试场景是对测试需求覆盖路径的一个分支。通过对测试场景的分析设计，可产生一批相同测试流程的测试用例。

路径：

【TestCenter】-【测试需求】-【测试需求】-【用例场景】

描述：

点击新建需求场景

截图：

步骤：

1. 点击添加

2. 输入下列表格中相应栏位

栏位名称 | 描述 | 特殊要求
场景名称 | 输入场景名称 | 1.不能为空 2.不能重复
频度 | 输入数字 | 1.不能超过100 2.不能为空
RBT | 下拉框选择需求状态 | 1.不能超过100 2.不能为空
复杂度 | 下拉框选择需求优先级 | 1.不能超过100 2.不能为空
附件 | 上传附件 | 1. 支持各种格式文件 2. 不能超过15M
备注 | 输入备注 |
是否连续添加 | 勾选可以连续添加需求 |

3.点击确定新增场景成功


4.1.3.4 场景用例设计 - TestCenter5.5帮助文档

4.1.3.4 场景用例设计

1、组件配置

路径：

【TestCenter】-【测试需求】-【测试需求】-【用例场景】-【场景设计】

描述：

点击进行组件添加

截图：

步骤：

1. 点击添加

2. 输入下列表格中相应栏位

栏位名称 | 描述 | 特殊要求
组件名 | 输入组件名称 | 1.不能为空 2.不能重复
原型 | 点击查询选择组件原型，即业务组件内的相关脚本 |
描述 | 输入描述 |
是否连续添加 | 勾选可以连续添加组件 |

3.点击确定配置组件成功

2、添加输出参数

路径： | 【TestCenter】-【测试需求】-【测试需求】-【用例场景】-【场景设计】
描述： | 点击进行输出参数的添加，该输出参数显示与所选定的组件栏位一致。
截图： |
步骤： | 1. 点击添加 2. 选中输出参数 3. 点击确定，输出参数添加成功

3、数值传递

路径： | 【TestCenter】-【测试需求】-【测试需求】-【用例场景】-【场景设计】
描述： | 点击进行数值传递
前提： | 至少存在2个组件，才可以进行数值传递，数值传递可保证所选的栏位字段使用相同的数据
截图： |
步骤： | 1. 点击添加数值传递 2. 选中组件1中的参数 3. 选中组件2中的参数 4. 点击确定，数值传递设置成功

4、用例设计

路径： | 【TestCenter】-【测试需求】-【测试需求】-【用例场景】-【用例设计】
描述： | 自动化用例设计，根据所选的组件，设置用例的参数信息，执行用例时使用这些数据进行测试。
截图： |
步骤： | 1. 点击添加默认数据 2. 输入用例名称以及栏位数据值 3. 点击保存按钮 4.提示是否重新关联数据池，点击是进行保存，提示生成用例成功


4.1.3.5 新建测试集 - TestCenter5.5帮助文档

4.1.3.5 新建测试集

TestCenter中自动用例执行是以测试集为单位进行执行，可以在测试集中添加需要执行的用例。

路径：

【TestCenter】-【测试构建】-【测试集】

描述：

新建测试集绑定测试用例

截图：

步骤：

1.点击新建组输入下列表格相应栏位

栏位名称 | 描述 | 特殊要求
名称 | 输入测试集组名称 | 1.不能为空 2.不能重复
描述 | 输入测试集组描述 |
是否连续添加 | 勾选是否连续添加按钮，可以连续添加多个测试集组，此框不消失 |

2.点击新增测试集输入下列表格相应栏位

栏位名称 | 描述 | 特殊要求
名称 | 输入测试集名称 | 1.不能为空 2.不能重复
描述 | 输入测试集描述 |
是否连续添加 | 勾选是否连续添加按钮，可以连续添加多个测试集组，此框不消失 |

3. 点击新增关联用例

4. 展开测试用例组，勾选需要添加的用例

5. 点击确定添加测试集用例成功

6. 展开用例路径展示相应添加的测试用例


4.1.3.6 新建测试计划 - TestCenter5.5帮助文档

4.1.3.6 新建测试计划

测试集需要与测试计划下的轮次进行绑定进行自动化用例执行，所以需要新建测试计划-版本-轮次。

1) 新建版本

路径：

【TestCenter】-【测试计划】-【测试计划】

描述：

测试计划关联在版本上，所以必须先创建版本

截图：

步骤：

1. 点击新建测试版本输入下列表格相应栏位

栏位名称 | 描述 | 特殊要求
版本名称 | 输入待测试软件的版本号 | 1.不能为空 2.不能重复
开始/结束时间 | 下拉框选择此版本测试开始结束时间 | 1.开始时间小于结束时间
描述 | 对此版本的描述 |
是否连续添加 | 确定则此框不消失，可以继续添加版本 |

2. 点击确定完成版本的新增

2) 新建计划

路径：

【TestCenter】-【测试计划】-【测试计划】

描述：

选择版本，新增计划

截图：

步骤：

1. 选中版本，点击新增计划输入下列表格相应栏位

栏位名称 | 描述 | 特殊要求
计划名称 | 输入此次测试计划名称 | 1.不能为空 2.不能重复
计划开始/结束时间 | 下拉框选择此测试计划开始结束时间 | 1.开始时间小于结束时间
测试目标与范围 | 此次测试的目标与范围 |
测试策略 | 此次测试的测试策略 |
测试环境 | 此次测试的测试环境 |
描述 | 此次测试的其他描述 |
是否连续添加 | 确定则此框不消失，可以继续添加版本 |

2. 点击确定按钮新增计划

3) 新建版本

路径：

【TestCenter】-【测试计划】-【测试计划】

描述：

选择计划，新增轮次

截图：

步骤：

1. 选择计划，点击新增轮次输入下列表格相应栏位

栏位名称 | 描述 | 特殊要求
轮次名称 | 输入轮次名称 | 1.不能为空 2.不能重复
开始/结束时间 | 下拉框选择此轮次开始结束时间 | 1.开始时间小于结束时间
描述 | 对此轮次的描述 |
是否连续添加 | 确定则此框不消失，可以继续添加轮次 |

2. 点击确定，新增轮次

4) 关联测试集

路径： | 【TestCenter】-【测试计划】-【测试计划】
描述： | 选择计划，新增轮次
截图： |
步骤： | 1. 选择轮次，进入信息编辑页面 2. 点击【添加测试集】按钮，弹出测试集选择对话框 3. 勾选需要关联的测试集，点击确定按钮 4. 添加成功，测试集显示在列表下方


4.1.3.7 自动执行 - TestCenter5.5帮助文档

4.1.3.7 自动执行

上面流程图可以看出，进行自动执行是需要借助TestAgent将AutoRunner与TestCenter进行连接实现联跑流程。所以自动执行前我们参照3.2.4章节进行TestAgent配置与启动。之后可以按照以下步骤发起用例执行。

路径： | 【TestCenter】-【测试构建】-【测试集】
描述： | 测试集下直接点击自动执行发起进行用例自动执行
截图： |
步骤： | 1. 选择需要执行的测试集，点击自动执行发起 2. 勾选执行器所在的IP，在下拉框中选择AR，点击【加载】 3. 勾选执行器类型为2的执行器 4. 点击开始按钮，发起用例自动执行
备注说明： | 在自动运行结束之后，可以根据运行结果进行缺陷提交，并且会自动生成相应的测试报告。


4.1.3.8 自动测试报告 - TestCenter5.5帮助文档

4.1.3.8 自动测试报告

1) 轮次下测试报告

路径： | 【TestCenter】-【测试计划】-【版本】-【计划】-【轮次】
描述： | 查看轮次下的测试报告
截图： |
步骤： | 1. 点击自动测试报告 2. 选择相应的运行名称双击 3. 打开报告查看报告详情

2) 轮次下测试日志

路径： | 【TestCenter】-【测试计划】-【版本】-【计划】-【轮次】
描述： | 查看轮次下的测试日志
截图： |
步骤： | 1. 点击自动测试日志 2. 选择相应的运行名称双击 3. 打开日志查看相应的运行结果详情

3) 轮次下cycle信息

路径： | 【TestCenter】-【测试计划】-【版本】-【计划】-【轮次】
描述： | 轮次下选择Cycle信息，查看自动化执行报表、导出执行报表
截图： |
步骤： | 1. 点击查看自动化执行报表 2. 查看自动化执行报告详情

4) HTML日志

路径： | 【TestCenter】-【测试计划】-【测试计划】
描述： | 查看自动测试日志下的用例执行总览
截图： |
步骤： | 1. 点击自动测试日志 2. 查看用例执行总览 3. 点击用例编号，弹出用例明细页面


4.1.4 手工测试流程管理 - TestCenter5.5帮助文档

4.1.4 手工测试流程管理

上面这个流程图是TestCenter手工测试的一个大致流程，下面我们就根据流程图，进行一个完整的手工流程测试。

注：这里的流程是在新建项目与用户、分配权限和加入用户已经完成的基础上进行的前台项目流程的操作。如不清楚如何操作请具体查看4.1.1和4.1.2章节。


4.1.4.1 新建测试需求 - TestCenter5.5帮助文档

4.1.4.1 新建测试需求

测试需求是测试场景和测试用例的集合，可以把不同的场景和用例放在各自独立的测试需求中。

方法一：直接新建需求

路径：

【TestCenter】-【测试需求】-【测试需求】

描述：

点击进行测试需求的新建

截图：

步骤：

1. 点击添加子需求

2. 输入下列表格中相应栏位

栏位名称 | 描述 | 特殊要求
需求名 | 输入需求名称 | 1.不能为空 2.不能重复
RBT | 输入数字 | 3. 不能超过100 4. 不能为空
状态 | 下拉框选择需求状态 | 1.不能为空
优先级 | 下拉框选择需求优先级 | 1.不能为空
描述 | 输入描述 |
是否连续添加 | 勾选是否连续添加按钮，可以连续添加多个需求，此框不消失 |

3.点击确定新增需求成功

方法二：通过模板批量导入

路径： | 【TestCenter】-【测试需求】-【测试需求】
描述： | 通过导入模板创建需求
截图： |
步骤： | 1. 点击导入模板配置 2. 点击选择属性，输入对应列 3. 点击添加，属性列会显示相应的属性 4. 输入目录分隔符为/，输入起始行（因为一般第1行为列名，从第2行开始），输入起始页、结束页（实际填的值根据导入的Excel文件的页数决定） 5. 点击保存提示模板保存成功 6. 根据上面配置的模板属性去建需要导入的Excel文件，列名与模板中配置的属性列保持一致，如下图： 7. Excel文件配置成功后点击需求导入，提示导入成功，展开默认需求节点显示导入成功的需求信息


4.1.4.2 新建需求场景 - TestCenter5.5帮助文档

4.1.4.2 新建需求场景

需求中的用例场景是测试场景是对测试需求覆盖路径的一个分支。通过对测试场景的分析设计，可产生一批相同测试流程的测试用例。

路径：

【TestCenter】-【测试需求】-【测试需求】-【用例场景】

描述：

点击新建需求场景

截图：

步骤：

1.点击添加

2. 输入下列表格中相应栏位

栏位名称 | 描述 | 特殊要求
场景名称 | 输入场景名称 | 1.不能为空 2.不能重复
频度 | 输入数字 | 1.不能超过100 2.不能为空
RBT | 下拉框选择需求状态 | 1.不能超过100 2.不能为空
复杂度 | 下拉框选择需求优先级 | 1.不能超过100 2.不能为空
附件 | 上传附件 | 1. 支持各种格式文件 2. 不能超过15M
备注 | 输入备注 |
是否连续添加 | 勾选可以连续添加需求 |

3.点击确定新增场景成功


4.1.4.3 场景用例设计 - TestCenter5.5帮助文档

4.1.4.3 场景用例设计

1、场景设计

路径： | 【TestCenter】-【测试需求】-【测试需求】-【用例场景】-【场景设计】
描述： | 双击场景名称，进入场景设计和步骤设计
截图： |
步骤： | 1. 场景步骤设计，点击添加一条步骤 2. 编辑各个步骤的步骤信息、描述以及预期结果 3. 点击保存，添加成功 4. 场景数据设计同步骤1 2 3

2、用例设计

路径： | 【TestCenter】-【测试需求】-【测试需求】-【用例场景】-【用例设计】
描述： | 点击进行手工用例数据设计
截图： |
步骤： | 1. 点击添加默认数据 2. 编辑用例名称以及栏位数据值 3. 点击保存按钮，选择该用例，点击步骤设计内的导入图标 4. 可将场景步骤导入到用例步骤内，以实现快速添加用例步骤


4.1.4.4 新建测试用例 - TestCenter5.5帮助文档

4.1.4.4 新建测试用例

测试用例是为某个特殊目标而编制的一组测试输入、执行条件以及预期结果，以便测试某个程序路径或核实是否满足某个特定需求。

方法一：参加上面场景法用例设计

方法二：测试用例页面新建

路径：

【TestCenter】-【测试构建】-【测试用例】

描述：

新建测试用例

截图：

步骤：

1. 点击新增组输入下列表格对应栏位

栏位名称 | 描述 | 特殊要求
名称 | 输入用例组名称 | 1.不能为空 2.不能重复
描述 | 对用例组的描述 |
是否连续添加 | 确定则此框不消失，可以继续添加用例组 |

2. 点击确定新增用例组

3. 点击新增用例输入下列表格对应栏位

栏位名称 | 描述 | 特殊要求
用例名 | 输入用例名称 | 1.不能为空 2.不能重复
版本 | 输入用例版本 |
描述 | 对用例组的描述 |
是否连续添加 | 确定则此框不消失，可以继续添加用例 |

4. 点击确定新增用例成功

5. 用例步骤设计，点击添加一条步骤

6. 编辑各个步骤的步骤信息、描述以及预期结果

7. 点击保存，添加成功

8. 场景数据设计同步骤1 2 3


4.1.4.5 新建测试集 - TestCenter5.5帮助文档

4.1.4.5 新建测试集

TestCenter中手工用例执行是以测试集为单位进行执行，可以在测试集中添加需要执行的用例。

路径：

【TestCenter】-【测试构建】-【测试集】

描述：

新建测试集绑定测试用例

截图：

步骤：

1.点击新建组输入下列表格相应栏位

栏位名称 | 描述 | 特殊要求
名称 | 输入测试集组名称 | 1.不能为空 2.不能重复
描述 | 输入测试集组描述 |
是否连续添加 | 勾选是否连续添加按钮，可以连续添加多个测试集组，此框不消失 |

2.点击新增测试集输入下列表格相应栏位

栏位名称 | 描述 | 特殊要求
名称 | 输入测试集名称 | 1.不能为空 2.不能重复
描述 | 输入测试集描述 |
是否连续添加 | 勾选是否连续添加按钮，可以连续添加多个测试集组，此框不消失 |

3. 点击新增关联用例

4. 展开测试用例组，勾选需要添加的用例

5. 点击确定添加测试集用例成功

6. 展开用例路径展示相应添加的测试用例


4.1.4.6 新建测试计划 - TestCenter5.5帮助文档

4.1.4.6 新建测试计划

测试集需要与测试计划下的轮次进行绑定进行手工用例执行，所以需要新建测试计划-版本-轮次。

路径：

【TestCenter】-【测试计划】-【测试计划】

描述：

新建测试计划下的测试版本，测试计划，测试轮次

截图：

步骤：

1.点击新建测试版本输入下列表格相应栏位

栏位名称 | 描述 | 特殊要求
版本名称 | 输入待测试软件的版本号 | 1.不能为空 2.不能重复
开始/结束时间 | 下拉框选择此版本测试开始结束时间 | 1.开始时间小于结束时间
描述 | 对此版本的描述 |
是否连续添加 | 确定则此框不消失，可以继续添加版本 |

2.点击新增计划输入下列表格相应栏位

栏位名称 | 描述 | 特殊要求
计划名称 | 输入此次测试计划名称 | 1.不能为空 2.不能重复
计划开始/结束时间 | 下拉框选择此测试计划开始结束时间 | 1.开始时间小于结束时间
测试目标与范围 | 此次测试的目标与范围 |
测试策略 | 此次测试的测试策略 |
测试环境 | 此次测试的测试环境 |
描述 | 此次测试的其他描述 |
是否连续添加 | 确定则此框不消失，可以继续添加版本 |

3.点击新增轮次输入下列表格相应栏位

栏位名称 | 描述 | 特殊要求
轮次名称 | 输入轮次名称 | 1.不能为空 2.不能重复
开始/结束时间 | 下拉框选择此轮次开始结束时间 | 1.开始时间小于结束时间
描述 | 对此轮次的描述 |
是否连续添加 | 确定则此框不消失，可以继续添加轮次 |

4.点击添加测试集，勾选需要执行的测试集

5.点击确定，轮次中显示绑定的测试集信息


4.1.4.7 手工执行 - TestCenter5.5帮助文档

4.1.4.7 手工执行

路径： | 【TestCenter】-【测试计划】-【测试计划】
描述： | 轮次下直接点击发起手工执行
截图： |
步骤： | 1. 选择执行的测试集 2. 点击发起手工执行 3. 输入运行名称 4. 点击确定，测试集状态变为执行中 5. 当用例执行完成后，点击结束运行，可结束手动执行


4.1.4.8 分配执行人 - TestCenter5.5帮助文档

4.1.4.8 分配执行人

路径： | 【TestCenter】-【用例执行】-【手工执行】
描述： | 进行手工执行用例分配
截图： |
步骤： | 1. 双击运行名称 2. 点击分配角色，弹出分配用例对话框 3. 勾选需要分配的用例以及人员，右移至右侧显示框 4. 点击确定按钮，完成用例的分配


4.1.4.9 用例执行 - TestCenter5.5帮助文档

4.1.4.9 用例执行

路径： | 【我的任务】-【执行用例】
描述： | 根据用例步骤数据等信息执行用例
截图： |
步骤： | 1. 双击用例名称 2. 弹出用例信息界面，根据用例步骤、数据等信息执行用例 3. 根据执行结果，将用例状态置为正确、错误或者取消 4. 点击确定按钮，完成用例执行
备注说明： | 用例执行者只能执行分配到自己名下的用例，无法执行别人名下的用例，用例执行完成后用例信息列表会对应显示相应的状态


4.1.4.10 缺陷提交 - TestCenter5.5帮助文档

4.1.4.10 缺陷提交

路径：

【缺陷管理】-【缺陷视图】-【提交缺陷】

描述：

对执行用例过程中发现的缺陷进行管理，包括新增、处理等操作

截图：

步骤：

1.点击提交缺陷

2.输入下列表格相应栏位

栏位名称 | 描述 | 特殊要求
缺陷名 | 输入缺陷名称 | 1.不能为空
分类 | 点击文本框右边的“》”在弹出的界面选择分类 |
出现频率 | 下拉框选择缺陷出现频率 | 1.不能为空
最后期限 | 选择缺陷处理最后期限 |
选择角色 | 选择缺陷处理角色 | 1.不能为空
处理人 | 选择角色处理人 | 1.不能为空
优先级 | 下拉框选择缺陷优先级 | 1.不能为空
严重性 | 下拉框选择缺陷严重性 | 1.不能为空
摘要 | 摘要 |
说明 | 说明 |
附件 | 上传下载删除附件 |
是否连续添加 | 选中后在点击确定后出现新的缺陷提交页面 |

3.点击确定缺陷提交成功


4.1.4.11 测试报告和日志 - TestCenter5.5帮助文档

4.1.4.11 测试报告和日志

1、轮次下测试报告

路径： | 【TestCenter】-【测试计划】-【版本】-【计划】-【轮次】
描述： | 查看轮次下的测试报告
截图： |
步骤： | 1.点击手工测试报告 2.选择相应的运行名称双击 3.打开报告查看报告详情

2、轮次下测试日志

路径： | 【TestCenter】-【测试计划】-【版本】-【计划】-【轮次】
描述： | 查看轮次下的测试日志
截图： |
步骤： | 1. 点击手工测试日志 2.选择相应的运行名称双击 3.打开日志查看日志详情

3、轮次下测试报告

路径： | 【TestCenter】-【测试计划】-【版本】-【计划】-【轮次】
描述： | 查看轮次下的测试报告手工汇总
截图： |
步骤： | 1. 选择Cycle测试报告 2. 点击手工汇总 3. 点击导出轮次报表


5 后台管理 - TestCenter5.5帮助文档

5 后台管理

TestCenter测试管理系统分为后台和前台界面，后台管理界面只允许管理员用户登录，管理员登陆系统的主要目的是创建用户和项目以及对系统的数据进行管理和掌控，本身并不参与测试流程管理；而对整个系统进行测试流程管理则是管理员创建的项目用户登录前台界面进行操作的。

管理员（admin，111111）后台登录地址：http:localhost:8080/TestLab/Admin.swf

项目用户（用户名，密码）前台登录地址：http:localhost:8080/TestLab


5.1 团队建设流程 - TestCenter5.5帮助文档

5.1 团队建设流程

在一个项目开始最初，都要进行该项目的建立，人员分配，权限控制和数据管理等团队的建设，在团队建设完成的基础上，我们才可以开始整个项目的下一步实施。

管理员用户登陆后台系统后，开始对团队建设，对用户和项目以及系统的数据进行管理和掌控，一系列功能管理模块如下图所示：

包括：【个人账号】、【用户管理】、【项目管理】、【数据库备份】、【插件权限设置】、【缺陷流程定制】、【邮件设置】、【登陆历史】、【数据字典】、【许可证】。

每个功能模块的细节将在后续小节里一一介绍。

管理员的团队建设流程：


5.2 个人账号 - TestCenter5.5帮助文档

5.2 个人账号

管理员登录后台系统：

管理员用户（admin，111111）登录地址：http:localhost:8080/TestLab/Admin.swf

登录界面如下：

登录成功后，就是【个人账号】页面，在这个页面可以设置管理员的密码等相关信息。设置完成点击保存。

（注：灰色文本框为不可编辑区域，白色为可编辑区域。）

个人账号界面如下：


5.3 用户管理 - TestCenter5.5帮助文档

5.3 用户管理

点击【用户管理】进入用户管理模块，【用户管理】模块分为项目用户和管理员用户，项目用户模块主要是对项目用户进行包括添加、修改、删除以及用户导入等操作管理，管理员用户模块相应的是对管理员用户进行操作管理。


5.3.1 添加用户 - TestCenter5.5帮助文档

5.3.1 添加用户

点击【添加】按钮，进入创建项目用户界面：

输入相关信息，其中邮件为你在项目中接收邮件的地址，用户角色则是你在项目中的角色，点击保存生成项目用户，当然也可以选择“支持连续添加用户”连续添加。


5.3.2 修改用户 - TestCenter5.5帮助文档

5.3.2 修改用户

勾选需要修改的用户，点击【修改】按钮，可修改用户的基本信息，重置密码则可将用户密码重置为111111。


5.4 项目管理 - TestCenter5.5帮助文档

5.4 项目管理

点击【项目管理】进入项目管理模块，【项目管理】模块分为项目管理和项目群管理，项目管理主要是对项目进行新增、修改、删除项目以及项目的属性管理数据升级等操作。

点击新增项目按钮进入创建项目界面

点击“创建项目”按钮即可创建新项目

其中项目名称，项目代码，项目经理，测试计划开始时间，测试计划结束时间为必填项，最后点击保存，即可成功创建项目！

项目创建成功后，可在项目列表中查看新建的项目信息。


5.5 缺陷流程定制 - TestCenter5.5帮助文档

5.5 缺陷流程定制

缺陷被提交后，根据缺陷状态的不同，将提交到不同的人手中，直到缺陷状态变更为关闭，流程结束。这里我们就要进行一个缺陷流程的定制，支持整个项目缺陷状态的跟踪处理，直至缺陷关闭结束。


5.5.1 角色/状态管理 - TestCenter5.5帮助文档

5.5.1 角色/状态管理

点击【缺陷流程定制】进入缺陷流程定制模块，【项目管理】模块分为角色/状态管理和工作流设置，角色/状态管理主要是对角色进行新增、删除以及状态进行新增和删除的管理工作；这里工作流设置主要是展示各个项目的工作流情况，给予查看和展示的功能，不提供设置和编辑工作流的功能！

【缺陷流程定制】→单击“角色/状态管理”→单击“新增”按钮

新增角色和状态详细操作：见下图


5.5.2 工作流配置 - TestCenter5.5帮助文档

5.5.2 工作流配置

点击“工作流设置”标签，进入工作流设置界面，此处负责管理TestCenter中工作流，在工作流配置中可查看工作流

【缺陷流程定制】→单击“工作流配置”标签→选中一条工作流→单击“编辑”按钮→出现“编辑工作流配置”对话框（注：此处编辑工作流配置并没有编辑功能，只提供了工作流展示查看的功能！）

详细操作：见下图


5.6 邮件配置 - TestCenter5.5帮助文档

5.6 邮件配置

进入【邮件配置】，这里主要是配置邮件发送服务器（在邮件配置界面，设置邮件发送服务器的协议类型、发送服务器地址、登陆帐号、密码、选择是否加密、端口、URL连接地址；该邮件配置后，在缺陷管理中修改缺陷的状态，就可以通过自动发送邮件的形式发送给相关人员。

限制：用户为系统管理员用户

详细操作：见下图

此处为后台系统邮件配置：

邮件配置完成保存以后，点击邮件发送测试，发送成功，则邮件配置正确。

对应的则是前台项目用户的邮件设置：

在登录前台系统后，【系统设置】→【个人账号】，前台邮件设置界面如下：输入邮件的接收地址，点击保存。


5.7 登录历史 - TestCenter5.5帮助文档

5.7 登录历史

点击【登录历史】，进入登录历史模块，【登录历史】分为用户登录历史记录和当前在线用户。用户登录历史记录模块用来记录用户登录和退出系统的信息。

说明:（1）在用户登录历史记录界面中显示所有用户的登录和退出信息，包括登录帐号，登录IP，登录时间以及退出时间。

（2）“退出时间”中有显示用户当前是否登录。

详细操作：见下图


5.8 数据字典 - TestCenter5.5帮助文档

5.8 数据字典

点击【数据字典】，进入数据字典模块，这里主要是对项目模块单选属性，对属性值进行添加、删除和保存的操作。

详细操作：见下图


5.9 许可证 - TestCenter5.5帮助文档

5.9 许可证


5.9.1 申请许可证 - TestCenter5.5帮助文档

5.9.1 申请许可证

点击【许可证】，许可证模块分为申请许可证和导入许可证。因为我们的TC管理工具是有使用的权限和期限设置的，这里就需要我们进行许可证的申请和导入工作，有了许可才能正常使用我们的TC工具。

选择“申请许可证”，进行申请许可证操作。

详细操作：分别选择要支持的对象，使用期限和设置同时在线人数。点击确定，选择保存路径，保存生成的许可证申请文件（.rep文件）。把该文件发给我们的技术支持（support@spasvo.com）进行许可申请，等待我们的技术支持回复给您许可证导入文件（.lic文件）。


5.9.2 导入许可证 - TestCenter5.5帮助文档

5.9.2 导入许可证

收到我们技术支持回复的.lic文件以后就可以进行许可证导入操作了，选择“导入许可证”，选中.lic文件，打开，导入完成。

详细操作：见下图


5.10 授予权限 - TestCenter5.5帮助文档

5.10 授予权限


5.10.1 权限管理与项目管理 - TestCenter5.5帮助文档

5.10.1 权限管理与项目管理

管理员在后台完成用户和项目的创建以后，在测试项目开始之前，管理员项目经理还要登录前台测试系统：

前台登录地址：http:localhost:8080/TestLab

给项目人员授予权限并把用户加入项目，进行项目配置，为后续测试工作的开展做准备。项目经理为项目配置资源，通过以下几步，就可以组建你的项目团队了！

通过【权限管理】我们为你的项目中各个角色添加权限，通过【项目管理】我们把用户加入项目，对你的项目进行资源配置。

权限管理界面：

进入权限管理模块，点击导入默认权限，

之后我们可以根据需要增添一些角色，一般情况下默认权限也就够用了。

通过“新增”按钮，我们可以添加角色与功能，功能名称最好与角色名一致，在右侧的系统模块中，我们为每一个功能设定他的权限：

如图，我们为资深开发工程师设置了权限，最后别忘了点击“修改”按钮保存权限修改。

有时候我们需要为特定功能设定特殊的按钮权限，TC提供了按钮权限的修改功能，通过勾选对应的按钮权限，点击修改即可为功能分配按钮权限。一般情况下，添加模块权限时，已经默认添加了对应模块按钮的权限。


5.10.2 项目管理 - TestCenter5.5帮助文档

5.10.2 项目管理

当我们完成权限的设置后，我们可以开始【项目管理】了，最主要的，我们得找人来做这个项目！

选择要加入项目的人员，为他们分配角色与功能（这时候你就会发现功能名与角色名一致的好处了），点击“加入用户”将他们加入你的项目团队。

团员全部加入项目后，可以为他们订阅邮件，当缺陷有变化时 ，会自动发邮件给对应的人员。


5.10.3 缺陷流程定制 - TestCenter5.5帮助文档

5.10.3 缺陷流程定制

在测试过程中，发现缺陷是必然的，那么，怎么规范合理地处理跟踪缺陷？这里我们需要用到【缺陷流程定制】。

（注：这里的缺陷流程定制就是在项目开始的时候定制的，一旦项目提交过缺陷以后，这里的缺陷流程便无法更改。）

点击添加按钮添加缺陷流程步骤，以下会给出一个完整的缺陷流程定制过程：

通过设置状态，角色，目标状态，设置缺陷流程，点击“保存”完成缺陷流程的定制。

此处定制完成后的缺陷流如下：

首先，测试员新建缺陷→测试负责人确认缺陷→开发负责人分配缺陷→开发工程师修改，修改完成→测试员关闭缺陷；开发负责人分配缺陷后→开发工程师驳回缺陷→测试员重开→开发工程师修改，修改完成→测试员再次重开→开发工程师驳回→测试员关闭缺陷。

至此，项目经理已经完成了项目的资源配置，之后就该由测试负责人接手了。


6 前台测试管理 - TestCenter5.5帮助文档

6 前台测试管理

在后台管理员新建项目与用户、前台项目经理给项目用户分配权限以及给项目加入用户等操作已经完成的基础上，就可以进行前台测试项目流程的操作了。

项目用户登录前台测试管理系统进行测试项目工作：

项目用户（用户名，密码）登录前台地址：http:localhost:8080/TestLab

软件测试流程：


6.1 测试需求 - TestCenter5.5帮助文档

6.1 测试需求

每一个项目的开始，都是由于需求的存在，项目要做的第一件事就是创建需求。

需求管理流程:


6.1.1 创建需求 - TestCenter5.5帮助文档

6.1.1 创建需求

通过TestCenter主菜单进入【测试需求】模块：

这里，我们可以通过两种方法添加需求，一种是通过添加子需求，需求分析，创建需求；另一种是导入需求。

首先，通过添加子需求，我们开始需求分析

添加子需求，点击确定完成添加

添加兄弟需求，点击确定完成添加

通过添加子需求与兄弟需求，我们对需求进行细分

点击保存按钮进行保存。需求细分也可以在之后由对应的需求分析人员完成。

方法二：导入需求，首先点击 [image] 导入模板配置，进行需求模板配置，选择属性对应列，添加，保存：

需求模板配置完以后，设置与模板相同格式的excel需求文档，点击 [image] 需求导入，打开保存。


6.1.2 需求细分 - TestCenter5.5帮助文档

6.1.2 需求细分

当项目交给测试负责人后，测试负责人将带领手下的测试员进行具体的需求分析，通过兄弟需求与子需求进行需求细分。


6.1.3 需求评审 - TestCenter5.5帮助文档

6.1.3 需求评审

在完成需求分析后，我们需要进行需求评审

点击“添加”按钮添加需求评审人员

加入评审人员，此处注意评审人员的权限，不是所有人都可以评审

开始评审

评审的结果

评审结束！

当我们完成需求分析及需求评审后，我们可以开始写测试计划了。


6.2 测试计划 - TestCenter5.5帮助文档

6.2 测试计划

当完成需求评审后，我们可以开始制定测试计划了。

进入【测试计划】模块：


6.2.1 版本管理 - TestCenter5.5帮助文档

6.2.1 版本管理

新建一个版本，通过版本可以控制你的测试进度。

点击确定完成版本创建

如有需要可以删除版本


6.2.2 计划管理 - TestCenter5.5帮助文档

6.2.2 计划管理

创建计划

点击确定完成计划创建

如有需要可以删除计划


6.2.3 轮次管理 - TestCenter5.5帮助文档

6.2.3 轮次管理

为你的计划设定测试轮次

点击确定完成轮次创建

如有需要可以删除轮次

漂亮的版本—计划—轮次结构可以很好的帮助你控制测试进度。


6.2.4 关联需求 - TestCenter5.5帮助文档

6.2.4 关联需求

在设计完版本后，我们需要为不同版本关联对应的需求

点击“关联需求版本”进入关联需求页面

点击需求将需求加入右侧列表，当需求全部加入右侧列表后点击确定，关联需求成功。

记得保存，同时也可以删除需求


6.3 用例设计 - TestCenter5.5帮助文档

6.3 用例设计


6.3.1 测试用例设计 - TestCenter5.5帮助文档

6.3.1 测试用例设计

在完成需求评审后，我们就可以开始设计测试用例了。

TC提供两种用例设计的方法，首先来看一般的用例方法：

由主菜单进入【测试用例】设计模块：

首先新增组

输入名称与描述，点击确定生成组

点击“新增用例”按钮新增用例

输入“用例名”，点击“确定”生成测试用例，当让我们也可以加上版本与描述，以方便我们未来管理用例。

点击用例，进入用例步骤设计：

依照顺序说明这些按钮的功能：增加一条步骤，插入步骤，保存步骤，删除步骤，导入场景步骤，步骤上移，步骤下移，添加用例数据，保存用例数据，删除用例数据。

在添加完步骤与数据后，点击保存，一条用例就设计完了。

在之前用例设计里有一个“导入场景步骤”按钮，这是做什么的呢？


6.3.2 用例场景与通过场景设计测试用例 - TestCenter5.5帮助文档

6.3.2 用例场景与通过场景设计测试用例

场景，这就是TC自有的另一种用例设计方法。

在设计用例时，经常可以碰到步骤完全相同。只是输入数据与输出数据不同的用例，这样一条条写是不是很麻烦？这时候我们就可以用场景来设计测试用例了。

点击【测试需求】，在【测试需求】模块的用例场景为对应的需求添加场景：

输入场景名称，点击“确定”生成场景；

双击场景名称进入场景设计

场景设计页面

通过添加场景步骤来生成场景，注意：场景中没有预期结果，场景只是动作的集合。

设计完步骤后点击“保存”完成场景设计

别忘了保存下需求！

现在返回我们的【测试用例】模块：

首先关联需求，点击“关联需求”

选择要关联的需求（该需求已经设计了场景），选择场景，点击确定关联成功

选择导入关联场景步骤

点击“是”完成导入

导入的步骤没有预期结果

为每一步添加预期结果

点击保存按钮，用例设计完成


6.3.3 用例评审 - TestCenter5.5帮助文档

6.3.3 用例评审

在设计完用例后，我们需要对用例进行评审，用例评审任务的创建有两种方法：

一是在【测试用例】模块，【用例评审】，新增评审用户，评审用例；

二是在【我的任务】，【评审任务】创建任务，评审任务。

（注：此处第一种方法仅在证券版自动化测试系统存在。）

这里在【测试用例】模块进行用例评审：

点击选择评审人员

勾选评审人员，点击完成，评审人员添加成功，此处注意评审人员的权限，不是所有人都可以评审

点击“评审用例”按钮进行评审

类型下拉框选择”已审核”，备注里可以对此次评审情况进行备注描述，点击“添加”完成评审

评审成功。点击确定返回之前页面


6.4 测试集 - TestCenter5.5帮助文档

6.4 测试集


6.4.1 构建测试集 - TestCenter5.5帮助文档

6.4.1 构建测试集

在评审完测试用例后，我们需要开始构建【测试集】。测试集，顾名思义，就是许多测试用例的集合，我们可以把测试用例添加到测试集，后由测试集集中运行测试用例。

首先，创建测试集：

进入【测试集】模块

首先新建组

输入组名，点击“确定”完成添加

点击“新增测试集”为测试组新增测试集

输入测试集名，点击确定，完成添加

通过添加测试组与测试集，构建完成测试集树，如下图所示：


6.4.2 测试集关联测试用例 - TestCenter5.5帮助文档

6.4.2 测试集关联测试用例

这里为测试集关联测试用例，把测试用例添加进测试集里：

勾选需要关联的用例，点击确定完成关联

用例与测试集关联成功。


6.4.3 测试轮次关联测试集 - TestCenter5.5帮助文档

6.4.3 测试轮次关联测试集

在测试用例与测试集完成关联后，我们需要将测试轮次与测试集进行关联，

进入测试计划，选择轮次，点击“添加测试集”为轮次添加测试集

勾选所需测试集，点击确定完成测试集的添加

添加测试集完成

在完成轮次关联测试集后，我们就可以开始执行用例了！


6.5 发起手工执行 - TestCenter5.5帮助文档

6.5 发起手工执行

手工测试执行管理流程：

发起执行我们主要也有两个入口：一是在【测试集】模块；二是在【测试计划】轮次下发起执行。

这里以在【测试集】模块发起手工执行为例：


6.5.1 分配用例执行 - TestCenter5.5帮助文档

6.5.1 分配用例执行

在发起手工执行后，我们需要将用例分配给对应的测试人员进行测试

在【用例执行】【手工执行】模块，双击运行名称，进入对应活动

点击进入人员分配

点击 [image] 分配角色，将人员与用例对应选入右侧列表

点击确认完成任务分配。

在完成任务分配后就可以开始执行用例了。


6.5.2 用例执行 - TestCenter5.5帮助文档

6.5.2 用例执行

以测试员的身份登陆前台测试管理系统后，在【我的任务】，【执行用例】模块

可以看到测试员zhangchong有许多未执行用例，双击用例，即可执行用例。


6.5.3 提交缺陷 - TestCenter5.5帮助文档

6.5.3 提交缺陷

执行测试就会有缺陷，缺陷的管理流程如下：

我们这里提交缺陷主要有两种方法：

一种是在【用例执行】→【手工执行】中，当执行状态为错误时，会出现“提交缺陷”按钮，点此按钮进行缺陷提交，如下图：

二是，在【缺陷管理】→【缺陷视图】中：

点击 [image] 提交缺陷，出现提交缺陷对话框，提交缺陷，点击确定。


6.5.4 缺陷处理流程 - TestCenter5.5帮助文档

6.5.4 缺陷处理流程

还记得之前做的缺陷流程定制么？当缺陷被提交后，根据缺陷状态的不同，将提交到不同的人手中，直到缺陷状态变更为关闭，流程结束。下面仅以测试负责人做一个示例：

测试负责人接到缺陷通知，点击缺陷ID 进入缺陷处理--编辑

点击“进入”进行编辑，测试负责人确认是否为缺陷后，选择角色和处理人，点击“保存”，将缺陷交给下一个环节的处理人


6.5.5 快速处理 - TestCenter5.5帮助文档

6.5.5 快速处理

除了按照上面的方法处理缺陷外，也可以双击缺陷进入快速处理界面：


6.5.6 查看执行报表 - TestCenter5.5帮助文档

6.5.6 查看执行报表

当测试在执行中的时候，项目经理希望可以看到项目进度，这在哪里呢？

进入【测试计划】，选择对应的轮次，有一个进度报告，可以通过进度报告了解项目进度。

关联缺陷则可以为轮次关联发现的缺陷，以便更好地完成版本控制

在项目进度中，则可以查看相关项目的其他一些报表


6.5.7 停止手工执行 - TestCenter5.5帮助文档

6.5.7 停止手工执行

当测试任务结束后，我们需要停止测试执行

在【用例执行】【手工执行】模块，选择相关用例，点击结束运行：

点击“是”，执行结束

当手工执行结束时，我们就看不到进度报告了，相对的，我们可以查看该轮次的测试报告。


6.6 查看缺陷报告 - TestCenter5.5帮助文档

6.6 查看缺陷报告

在【缺陷管理】--【统计报表】中可以看到有关缺陷的报告

输入开始与结束时间，可以得到特定时间内的统计报表，右下角可以选择导出报表


6.7 TC与AR的联跑 - TestCenter5.5帮助文档

6.7 TC与AR的联跑

在前面《快速入门》章节，我们已经介绍了TC自动化测试流程的管理，这里来具体介绍一下TC与AR连跑的自动化测试流程，包括测试环境的安装配置、前后台的管理、AR上的脚本录制、组件配置、以及测试项目管理的流程、自动执行以及自动测试报告等。


6.7.1 配置安装 - TestCenter5.5帮助文档

6.7.1 配置安装

要实现TC与AR的连跑就首先要完成TC与AR的安装和相关配置：

1、安装TC

2、安装AR

3、安装TestAgent

4、启动Tomcat（TC服务）

5、启动tnameserv.exe（C:\Program Files\Java\jdk1.6.0_45\bin\tnameserv.exe，因为java 的版本与安装路径不同，程序位置也会有点变化）

6、启动并配置TestAgent

点击“确定”关掉错误提示，出现此错误是因为还没有完成配置信息。

点击“配置”开始配置

本机IP地址为：192.168.10.67

TC服务器IP地址为：192.168.10.20

在配置中出现的服务器IP地址都是指的TC服务器的IP地址

注意：每一个标签页均需要保存设置。

运行器配置：

配置服务器IP

Tar配置

配置服务器IP

Autorunner配置：

配置服务器IP

自动运行配置：

配置服务器IP

配置AR路径：此处为安装在本机上的AR路径

启动TestAgent

启动成功后


6.7.2 TC后台管理 - TestCenter5.5帮助文档

6.7.2 TC后台管理

完成TC与AR的环境配置后，因为TC与AR的连跑是属于自动化测试类型，那么我们就要对TC的后台进行管理配置，我们要重新创建用户和项目，添加新项目选择测试类型为自动化测试

项目管理-添加新项目：

以创建的自动化测试项目登录前台证券版TC系统，准备实现与AR的连跑。


6.7.3 AR录制脚本 - TestCenter5.5帮助文档

6.7.3 AR录制脚本

1、首先，在AR中录制脚本，这里以计算器为例：

录制脚本前新建项目和脚本，这里可以对录制程序设置，选择不限定录制程序和限定录制程序，并对程序进行相应参数和工作目录的设置。

点击录制按钮，鼠标左键点击实现录制动作，还可以通过Ctrl+alt+鼠标指针悬停捕获对象，捕获的对象可在对象库中查看是否存在，是否捕获成功：

编辑脚本，参数化。

把这段脚本：

ar.window("CalcFrame_计算器").clickControl("Button_1", 20, 10, "left");

ar.window("CalcFrame_计算器").clickControl("Button_加", 15, 4, "left");

ar.window("CalcFrame_计算器").clickControl("Button_5", 25, 9, "left");

ar.window("CalcFrame_计算器").clickControl("Button_等于", 17, 29, "left");

ar.window("CalcFrame_计算器").clickControl("Button_清除", 16, 16, "left");

进行参数化编辑，编辑后如下：

for(ParameterData pd : ar.getParameterDataList("calc.xls")/*.subList(0, 2)*/)

{

ar.parameterData = pd;//ar.parameterData可用于脚本之间传递参数

ar.window("CalcFrame_计算器").clickControl("Button_1"+ar.parameterData.getFrom("a"));

ar.window("CalcFrame_计算器").clickControl("Button_"+ar.parameterData.getFrom("b"));

ar.window("CalcFrame_计算器").clickControl("Button_"+ar.parameterData.getFrom("c"));

ar.window("CalcFrame_计算器").clickControl("Button_等于", 17, 29, "left");

ar.window("CalcFrame_计算器").clickControl("Button_清除", 16, 16, "left");

}

注意：这里可能会需要手动添加对象到对象库，保证参数列表内的参数在对象库中存在。

注：脚本回放没有问题，之后我们返回TC开始TC与AR的联跑。


6.7.4 TC组件配置 - TestCenter5.5帮助文档

6.7.4 TC组件配置

（1）首先我们进入TC，创建一个业务组件，在【测试构建】，【业务组件】

点击“新建组”开始创建

输入组件名称，点击“确定”完成创建

创建完成

新建自动组件，导入AR脚本

按照下图进行设置

导入脚本时需要将3个文件（.bsh .xls.xml）一起导入，点击”打开”完成导入

加载脚本成功：

对脚本进行编辑，然后点击“修改”按钮，保存编辑

点击修改按钮后，提示修改成功，点击“确定”完成编辑


6.7.5 用例设计 - TestCenter5.5帮助文档

6.7.5 用例设计

在完成自动化脚本的编辑后，我们需要设计一个自动化测试用例

那么，我们的自动化用例设计主要也有两种方法：

一种是，我们在前面手工测试里提到过的，在【测试需求】--【用例场景】--【场景设计】里，通过组件配置，自动设计用例；

二是通过【辅助插件】用例设计，设计测试用例。

首先，我们创建一个空白需求

然后，方法一：我们就通过【测试需求】【用例场景】添加场景，设计自动用例

添加场景

双击场景名称进入【场景设计】，在【场景设计】场景设计，组件配置里， [image] 新增依赖组件

填写组件名--搜索原型组件，选择组件，双击为确定--点击确定

然后进入用例设计-自动用例数据设计- [image] 添加默认数据，定义用例名称--保存，可配置多条数据，对应生成多条用例

自动生成的用例可在【测试构建】--【测试用例】查看。

方法二：我们使用【辅助插件】--用例设计，来帮助设计测试用例

选中需求，点击“快速添加”

单击活动图名，右侧出现活动图

点击组件设计，选择远程组件

点击“绑定”

完成绑定

进入“场景设计”，选择场景，点击“保存”保存组件信息

进入数据设计，双击组件名称，自动添加“测试项信息”与“步骤信息”

双击测试项信息添加数据，添加内容后，点击“添加”将内容加入数据点击“关闭”完成添加

测试项设计：勾选测试项后，点击检索

进入用例设计，勾选用例

输入测试项名称，点击“保存”

进入“用例设计”选择场景导入，输入场景名称（之前建立的需求名称），点击“导入”按钮导入，用例设计完成。


6.7.6 TC轮次关联测试集 - TestCenter5.5帮助文档

6.7.6 TC轮次关联测试集

TC创建一个测试集，将设计好的用例加入进去

创建一个测试计划，轮次关联测试集


6.7.7 自动执行 - TestCenter5.5帮助文档

6.7.7 自动执行

方法一：【测试集】--选择测试集--自动发起执行（注：用例未勾选默认全部执行，若有勾选则为指定执行）

方法二：【测试计划】--测试版本--测试计划--测试轮次--选择测试集--批量自动运行

这里，在【测试集】中发起自动执行，选择执行器，点击“开始”，TC与AR的联跑就完成了


6.7.8 自动执行报告与日志 - TestCenter5.5帮助文档

6.7.8 自动执行报告与日志

在【测试计划】轮次下可查看自动测试报告与自动测试日志：

自动化测试报告：测试计划--轮次--自动化测试报告

双击进行查看


7 特点介绍 - TestCenter5.5帮助文档

7 特点介绍


7.1 分布式执行 - TestCenter5.5帮助文档

7.1 分布式执行

TestCenter通过TestAgent与AutoRunner进行交互，实现了多任务、多执行器的并发运行结构。


7.2 缺陷处理流程定制 - TestCenter5.5帮助文档

7.2 缺陷处理流程定制

缺陷管理中的缺陷处理流程，可以根据用户的实际需求进行定制，定制后的处理流程将更加适合项目管理者了解项目进度和把控缺陷的处理效率。

注：缺陷流程定制需要在项目中没有提交缺陷引用过流程才可以进行配置，如果已经引用默认流程提交了缺陷，是无法进行修改配置的。


7.3 数据导入导出 - TestCenter5.5帮助文档

7.3 数据导入导出

对于一个测试集，对其进行一次又一次的运行，其中每次所用到的数据都不一样，我们只需要对测试集中的数据进行修改，保存后运行时所采用的数据就是所修改的数据。而有的时候已经测试过的数据需要重新用来测试，这时，我们可以先把数据保存下来，可以用导出数据来实现。当我们需要重新来测试这些数据时，只需要把数据导入进来就可以应用。


7.4 统计报表 - TestCenter5.5帮助文档

7.4 统计报表

在TestCenter测试管理工具中自动执行测试计划、手工执行测试计划、缺陷管理统计等都会自动产生各种统计图表，用户可直接通过这些图表查看最终执行的结果，同时还可以对不同的统计图表进行对比。（具体详细操作参考4.1.3自动化测试流程章节中的测试报告模块）


7.5 用例复用 - TestCenter5.5帮助文档

7.5 用例复用

复杂的应用系统往往具有大量的测试用例。在实际的使用中，为了便于管理会把部分的测试用例做成测试集来使用，然后使用一个大的测试集来包括多个小的测试集。

TestCenter支持这种复杂的嵌套关系，支持多层次的嵌套，并且能够通过执行外部的测试集来完成测试工作。通过测试集方便地进行测试用例的复用。


8 常见问题 - TestCenter5.5帮助文档

8 常见问题


8.1 Tomcat - TestCenter5.5帮助文档

8.1 Tomcat


8.1.1 Tomcat启动失败 - TestCenter5.5帮助文档

8.1.1 Tomcat启动失败

1．启动报-8错误

解答：如果使用的是win8系统，建议更换为win7系统；如果是win7系统的话，因为权限不够导致，建议使用超级管理员用户来操作

2．启动tomcat报错

可能是环境变量配置过tomcat，到环境变量里面看一下有没有CATALINA_HOME这个。因为我们TC的tomcat是规定，如果配置了CATALINA_HOME启动tomcat时就直接找的是CATALINA_HOME指向的那个，而不是我们TC。可以把TC的TestLab拷到CATALINA_HOME指向的软件目录下。

3．win7，64位，启动tomcat闪退

win7 64位操作系统在安装jdk的时候安装的是64位jdk，这个时候让客户下载32位jdk进行安装，并按照32位jdk的路径重新配置环境变量。配置完成后重启Tomcat正常运行。

4. 启动Tomcat，启动信息提示有拒绝访问现象

在Tomcat启动中有拒绝访问的提示，这种可能是由于在win7系统下权限不够造成的。

有两种解决办法：

在启动Tomcat的时候要以右键选择管理员身份运行。

在运行中输入cmd，cd C:\Program Files\Spasvo\TestCenter\tomcat5.5\bin

进入到目录后运行Testcenter.bat

就能正常启动。


8.1.2 Tomcat能够成功启动但是无法跳转到登陆界面则有可能 - TestCenter5.5帮助文档

8.1.2 Tomcat能够成功启动但是无法跳转到登陆界面则有可能

总体思想：TestCenter的网页服务程序是tomcat，TestCenter的数据库是MySql，同一台机器上可以安装两个tomcat，可以并行并行使。同一台机器所以当一台机器里已装有tomcat且可以共享给TestCenter使用时并且不能共享使用时。可以采取以下办法执行。分两种情况，一是安装有其他使用tomcat的程序。二是安装有旧版本的TestCenter

机器上安装有其他使用tomcat的程序需要更改的配置文件：

server.xml

位于：C:\Program Files\SpasvoSoft\TestCenter\tomcat5.5\conf

红色部分以实际安装路径为准

1> 第13行：

<Server port="8005" shutdown="SHUTDOWN">

将port="8005"改为：port="9005"

2> 第77行：

<Connector port="8080" maxHttpHeaderSize="8192"

将port="8080"改为port="9080"

3> 第94行：

<Connector port="8443" maxHttpHeaderSize="8192"

将Connector port="8443"改为Connector port="9443"

4> 第102行：

<Connector port="8009"

将port="8009"改为port="9009"

5> 第103行：

enableLookups="false" redirectPor01t="8443" protocol="AJP/1.3" />

将redirectPort="8443"改为redirectPort="9443"

6> 第108行：

<Connector port="8082"

将port="8082"改为port="9082"

（1） 存在端口占用情况（默认端口为8080），请修改server.xml文件，默认路径为：C:\ProgramFiles\SpasvoSoft\TestCenter\tomcat5.5\conf\server.xml，修改端口8080为可用端口，如：8089（可在server.xml中搜索所有8080并改为8089）。保存后，重启Tomcat，登录地址则相应改为：http://localhost:8089/TestLab；

如何查看端口有没有被占用：cmd ： netstat -a

已经启动了tomcat，也就是tomcat已经在用了。

（2） 环境变量可能配置了CATALINA_HOME（配置tomcat的路径），如果配置了该变量，就会默认找这个指定的路径。TC的就可能打不开。

（3） 还有可能是我们工具的flash 版本问题，客户机版本较低，需要安装插件，文件路径在：D:\ install_flash_player_10_active_x.exe。


8.1.3 Tomcat能够成功启动但是不能登陆成功 - TestCenter5.5帮助文档

8.1.3 Tomcat能够成功启动但是不能登陆成功

除了数据库连接问题外还有可能的原因是缺少下面几个文件：

C:\Program Files\Java\jdk1.6.0_20\jre\lib rt.jar

C:\ProgramFiles\Java\jdk1.6.0_20\jre\lib\security目录下的local_policy.jar/US_export_policy.jar以及C:\Program Files\Java\jdk16.0_20\jre\lib\ext下的：sunjce_provider.jar


8.1.4 Tomcat能够成功启动但是win7运行一段时间后关闭 - TestCenter5.5帮助文档

8.1.4 Tomcat能够成功启动但是win7运行一段时间后关闭

这可能是由于权限不够造成的，这时候需要在命令行中启动TC。

在cmd中输入cd C:\Program Files\Spasvo\TestCenter\tomcat5.5\bin

进入到相应目录后运行Testcenter.bat

就能正常启动。


8.1.5 Tomcat启动信息正常，但是还是无法进入系统 - TestCenter5.5帮助文档

8.1.5 Tomcat启动信息正常，但是还是无法进入系统

这个问题主要可能是客户在安装的时候，安全卫士或者杀毒有拦截造成的，如果客户同意拦截造成的。这个时候就需要重新安装TC，在安装之前，把安全卫士和杀毒关闭，重新安装完成就能解决相关问题。


8.2 mysql数据库 - TestCenter5.5帮助文档

8.2 mysql数据库


8.2.1 连接不上mysql数据库？ - TestCenter5.5帮助文档

8.2.1 连接不上mysql数据库？

不能连接上Mysql数据库的话分为以下三种情况：

（1） 若用户本机没有装有Mysql数据库的话则需要在安装TestCenter过程中需要选中“安装Mysql数据库”

（2） 若用户在本机中已经装有Mysql数据库的话，需要导入我们TestCenter的数据库database，该数据库文件testcenter.sql在文件夹TestCenter目录下（默认路径为C:\Program Files\SpasvoSoft\TestCenter），具体步骤如下：

a) 在“运行”中输入cmd，打开cmd窗口

b) 进入Mysql的bin目录，在cmd中输入cd C:\Program Files\MySQL\MySQL Server 5.0\bin（C:\Program Files\MySQL\MySQL Server 5.0\bin只是一个举例，用户需要根据自己的实际安装目录输入）

c) 输入mysql –uroot –proot 进入mysql数据库中；

d) 进入mysql后就可以导入TestCenter数据库文件testcenter.sql 了，输source C:\Program Files\SpasvoSoft\TestCenter\testcenter.sql

e) 导入成功会有如下显示；

完成以上步骤后就可以正常使用TestCenter。

（3） 若在本机装有Mysql数据库而且数据库自行设置过密码的话，则需要修改以下三个文件的password：

三个文件均在：

C:\ProgramFiles\Spasvo\TestCenter\tomcat5.5\webapps\TestLab\WEB-INF目录下

依次修改完以上三个文件的password，后导入testcenter.sql数据库表，可参考第（2）步。

备注：如果用户卸载完TestCenter后想再次安装TestCenter，则需要把原先的安装目录文件夹SpasvoSoft删除后再安装。


8.2.2 没有启动Mysql服务 - TestCenter5.5帮助文档

8.2.2 没有启动Mysql服务

在Tomcat中出现此类报错信息是由于没有启动mysql数据库服务造成的

解决方法：

（1） 若本机自己装有mysql数据库的话，则右键“我的电脑”--- 选择“管理”---“服务”--- 找到“Mysql”服务 --- 选择“启动”或者“重新启动”

（2） 若本机装了TestCenter自带的数据库的话，则右键“我的电脑”--- 选择“管理”---“服务”--- 找到“spasvoDBServer”服务 --- 选择“启动”或者“重新启动”。


8.2.3 数据库服务没有安装上。或者如下图： - TestCenter5.5帮助文档

8.2.3 数据库服务没有安装上。或者如下图：

这中状况很可能是修改安装目录了。我们的默认安装目录C:\Program Files\Spasvo\TestCenter。可以修改盘符，但是Spasvo\TestCenter这个之间不可以修改的，否则就找不到文件。


8.2.4 如果本机装有Mysql，在安装过程中也安装了我们自带的mysql5.5。那么启动tomcat的时候报错？ - TestCenter5.5帮助文档

8.2.4 如果本机装有Mysql，在安装过程中也安装了我们自带的mysql5.5。那么启动tomcat的时候报错？

处理办法：先停掉mysql原有的服务，重新启动spasvoDBServer服务。


8.2.5 基库导入操作 - TestCenter5.5帮助文档

8.2.5 基库导入操作

说明：新版TC安装后可能会出现基库未导入成功的情况，下面的步骤详细叙述了查看和导入基库的方法。

1 打开命令编辑框输入mysql –uroot -proot按回车，如图：

2 输入show databases；按回车，如图：如果没有红圈里的项，则表明基库未导入成功。

3 若基库未导入成功，则需手动导入，输入source按空格键，在桌面上找到TC启动图标 [image] 右键点击打开文件位置，在安装目录C:\Program Files\Spasvo\TestCenter下找到文件 [image] ，将该文件拖入命令编辑框中，如图：

4 在编辑框中把双引号删除按回车，基库就开始导入了。待数据刷新结束后即可关闭编辑界面。这时就可以成功启动Tomcat了。


8.2.6 如何注册数据库服务 - TestCenter5.5帮助文档

8.2.6 如何注册数据库服务

注册服务，通过控制台进入到刚刚复制的mysql bin目录 例如：D:\Program Files\Spasvo\TestCenter\DBSVR3310\bin>mysqld-nt.exe

Install mysql3310 --defaults-file="D:\Program Files\Spasvo\TestCenter\DBSVR3310\my.ini"


8.2.7 如何更改数据库端口 - TestCenter5.5帮助文档

8.2.7 如何更改数据库端口

1. E:\Program Files\Spasvo\TestCenter\DBSVR

a) 下面的my.ini

2. E:\Program Files\Spasvo\TestCenter\tomcat5.5\webapps\TestLab\WEB-INF

a) 下面的hibernate.cfg.xml

b) workflow_hiber.cfg.xml

把这三个文件的3306端口更改


8.3 TestCenter - TestCenter5.5帮助文档

8.3 TestCenter


8.3.1 TC安装问题 - TestCenter5.5帮助文档

8.3.1 TC安装问题

1 Tomcat启动后闪了一下就消失了？

出现这种情况有可能电脑的登录账户不是Administrator或者不是以管理员权限运行造成权限不够。

2 Tomcat启动后停留在如下页面，未成功启动？

出现这种情况一般是数据库服务mysql没有启动造成的

1） 用户电脑原来没有装Mysql数据库，装的是TC安装包自带的Mysql数据库，则可以到服务里面启动spasvoDBServer服务，启动后刷新一次再查看是否已启动，如果刷新后未启动，说明数据库端口被其他程序占用，可在进程里面找到Java相关的进程并关闭，再启动spasvoDBServer服务。

2） 用户电脑原来装了Mysql数据库，装TC的时候又装了安装包自带的Mysql数据库，到服务里面查看spasvoDBServer，如果没有该服务，说明安装包自带的Mysql数据库没有装上，停掉电脑原来装的Mysql数据库的服务，再重装TC；如果有该服务，但是没有启动，停掉原来的Mysql数据库服务，启动spasvoDBServer服务。

3） 用户电脑原来装了Mysql，装TC的时候没有装安装包自带的Mysql数据库，则需要手动导入数据库，该数据库文件testcenter.sql在文件夹TestCenter目录下（默认路径为C:\Program Files\Spasvo\TestCenter），步骤如下：

a)在“运行”中输入cmd，打开cmd窗口

b)进入Mysql的bin目录，在cmd中输入cd C:\Program Files\MySQL\MySQL Server 5.0\bin（C:\Program Files\MySQL\MySQL Server 5.0\bin只是一个举例，用户需要根据自己的实际安装目录输入）

c） 输入mysql –uroot –proot 进入mysql数据库中

d）进入mysql后就可以导入TestCenter数据库文件testcenter.sql 了，输source C:\Program Files\SpasvoSoft\TestCenter\testcenter.sql

e)导入成功会有如下显示

完成以上步骤后就可以正常使用TestCenter。

f)若在本机装有Mysql数据库而且数据库自行设置过密码的话，则需要修改以下三个文件的password：

三个文件均在：C:\ProgramFiles\Spasvo\TestCenter\tomcat5.5\webapps\TestLab\WEB-INF目录下

依次修改完以上三个文件的password，后导入testcenter.sql数据库表，可参考第（2）步。

备注：如果用户卸载完TestCenter后想再次安装TestCenter，则需要把原先的安装目录文件夹SpasvoSoft删除后再安装。


8.3.2 许可证问题 - TestCenter5.5帮助文档

8.3.2 许可证问题

1．导出TC REQ文件基本流程

第一步先打开tomcat.

第二步在开始栏中找到Testcenter

第三步点击运行TCLicence

第四步输入帐号：admin.密码：111111.

最后一步是导出许可证

接下来根据需求选择保存下来，把保存的文件发给我们公司技术支持就可以的。导入lic文件的步骤也是一样的。

2．lic过期，启动tomcat，输入账号密码，但是无法登陆lic申请

打开目录C:\ProgramFiles(x86)\Spasvo\TestCenter\tomcat5.5\webapps\TCLicence\WEB-INF\lisr，双击运行 [image] 即可导出许可证。

3．TC的lic文件导出路径是什么？

C:\ProgramFiles(x86)\Spasvo\TestCenter\tomcat5.5\webapps\TestLab\WEB-INF\lisr


8.3.3 项目用户管理问题 - TestCenter5.5帮助文档

8.3.3 项目用户管理问题

1．TC如何创建项目？

TC的项目是在后台界面建立项目，由管理员建立。

在网址栏输入http://localhost:8080/TestLab/Admin.swf

点击创建项目，输入项目信息，点击保存，完成项目添加

2．TC后台创建项目失败？

解答：先检查配置环境有没配置MYSQL_HOME的环境变量，如果没有就需要在环境变量中的用户环境变量中添加MYSQL_HOME的环境变量信息。

MYSQL_HOME

C:\Program Files\Spasvo\TestCenter\DBSVR

3．后台新建项目没显示？

这是浏览器没有刷新的原因，按照下图对浏览器进行设置后重新打开页面登录就好了

4．TC如何申请用户账号和密码？

首先登陆到后台，后台地址http://localhost:8080/TestLab/Admin.swf

后台的用户名：admin 密码：111111；前台的用户名需要在后台创建，然后到前台即可登录。

5．添加用户时出现add_pro_user_fail

解答：出现这种情况是因为创建的用户在创建项目的后面，进行数据升级就可以了，具体步骤如下：

第一步，进入到后台点击项目管理

第二步，选中该项目，例如：9.11这个项目，然后点击项目数据字典升级、数据升级


8.3.4 导入导出问题 - TestCenter5.5帮助文档

8.3.4 导入导出问题

1．在TestCenter中导出数据被浏览器阻止怎么办？

TestCenter中有多个功能点具有导入导出数据的功能，这是为了最大限度减少使用者的操作和增加TestCenter数据的高度复用性而设计的。由于市面上浏览器种类繁多。不排除某些浏览器会对TestCenter导出的数据加以阻止。经测试，目前TestCenter可以完好的支持IE6.0，IE7.0，IE8.0 火狐。导出数据时一般点击允许即可，如点允许后浏览器没有弹出下载数据文件.xls对话框则重新点击导出即可。

2．TC如何导入需求

在TC前台打开测试需求，可以查看到导入需求和导出需求按钮，可以根据自己想要的类容到处你所需要的需求信息。

2.在测试需求里面有导入导出需求选项；

3．用例导入标准格式

说明：导入用例前往往要进行用例模板配置，先导入模板配置，然后设置相同格式的excel用例，导入即可。

1 在测试用例模块，点击导入模板配置按钮

出现用例导入配置对话框，选择所需属性，设置对应列，添加，保存：

2设置与模板相对应的excel用例文档

3 点击 [image] 导入用例按钮

选择设置好的excel用例模板，打开保存，导入成功。

4．导入导出格式有哪些格式？

1）cycle测试报告，可以导出为PDF

PDF格式：

2)需求的导入和导出是xls格式

其模板显示

3)导入/导出测试用例其格式为.xls。其模板显示

4）缺陷观察报表导出格式为PDF

5）测试人员报告缺陷报表导出格式为PDF

6）日或周缺陷报表导出，格式为PDF

7）缺陷报表到出为PDF

5．无法导入sql语句？

使用模板导入数据时，用例数据不能过长且不能包含特殊字符，无法导入sql语句？

解决方法：由于导入的sql数据中出现了单引号，去掉单引号即可，并建议将sql放到公共脚本中去。


8.3.5 如何添加检查点 - TestCenter5.5帮助文档

8.3.5 如何添加检查点

1. 证券系统接口自动化，首先需要在测试需求下创建场景，进而在场景中配置组件，例如“股票的普通买入”，这个场景配置的组件如下所示：

2. 上面股票普通买入的场景其实是将金证接口做成的组件和专门用于计算和校验的组件结合起来拼成这样的一个场景进行测试，那么这样的场景下生成的用例测试点相对比较全面，不仅单独测到了涉及的所有接口，又测试了买入数量是否超过了最大交易数量&&资金的变化情况&&委托状态成功与否，那么这里涉及到一个问题：例如“买入校验最大交易数量”这个组件，是一个校验的组件，这个校验是如何实现的？用例执行之后校验点的校验结果怎么查看？如下，分三个步骤：

a、 接口的制作需要有校验点栏位；这里需要强调一下，410411是接口文档中的接口，我们是将其制作成Excel按照特定格式导入到TC，这个组件只有出参入参没有检查点，有检查点的组件是单独用作校验，“买入校验最大交易数量”是测试人员根据校验的需要制作的组件，如下，这个组件最初在设计Excel时，只有3个栏位：maxstkqty、yqqty和maxstkqty_check，其中2个是出参1个是检查点；其实maxstkqtyh和yqqty是入参也可以的，但我们一般做校验组件习惯性将非校验点的都设置为出参，其实除了校验点，其他字段是入参还是出参并不重要，他们存在的意义只是从前面的组件值传递到这些字段；校验点就不一样了，必须是C（检查点）：

导入到TC前的Excel：

导入到TC后作为组件存在，如下：

b、 第二步骤是需要校验点的组件中编写脚本，如下是脚本：

这个脚本具体剖析如下：

//第一步

Double yqQty = Double.parseDouble(ar.parameterData.getFrom("yqqty"));//从用例中获取yqqty字段的值（这个值是从计算预期成交金额的yqqty值传递过来），并将其转换为double类型

//第二步

Double sjMaxstkqty = Double.parseDouble(ar.parameterData.getFrom("maxstkqty"));//从用例中获取maxstkqty字段的值（这个值是从410410-取最大交易数量的maxunlimitstkqty值传递过来），并将其转换为double类型

//第三步，判断410410接口返回的最大交易数量是否大于等于用例中手工填写的交易数量，如果大于等于则说明买股票的数量在可允许范围内，换句话说就是校验点应该是正确的，ar.parameterData.putInto后面的括号有2个参数，一个是校验点字段名称maxstkqty_check，后面一个是字符串拼接起来，意思是委托数量+最大可委托数量+true；那么相反，如果小于yqQty，则将yqQty+";"+sjMaxstkqty+";false"这个拼接的字符串putInto到maxstkqty_check这个校验点字段；这里肯定很多读者会有疑问，脚本这样写的目的是什么？用例执行结束后怎么看校验点执行结果？校验点的校验结果对组件的执行结果甚至是用例的执行结果有何影响？下面第三步骤d会进行讲述

if ( sjMaxstkqty >= yqQty) {

ar.parameterData.putInto("maxstkqty_check",yqQty+";"+sjMaxstkqty+";true");}

else {

ar.parameterData.putInto("maxstkqty_check",yqQty+";"+sjMaxstkqty+";false");

throw new Exception("委托股份数量校验失败");

}

c、 通过a和b步骤实现了组件的导入和校验组件脚本的编写，还需要在组件配置à校验点中将校验点添加进来，添加后才能保证用例执行完可以在日志中查看，如下，切换到“校验点”选项卡，点击添加按钮，在弹出的页面中首先选择有校验点的组件，然后找到校验点字段，双击，右边会显示，点击确定即可添加成功：

d、 上面脚本中，如果走第一个分支，脚本没有异常抛出，起码可以说明该组件执行正确，至于整个用例是否执行正确这个文档就不再做过多描述（用例执行正确必须保证该用例执行后所有的组件都执行正确，是该用例场景下所有组件执行结果“与”的集合，如果该场景下有1个或1个以上组件运行失败，则用例执行结果就是失败），该校验组件无论执行成功还是失败都可以在测试轮次下à自动测试日志中查看某一次运行的记录，如下，从中找到对应的用例查看校验点结果，双击“买入校验最大交易数量”这个组件，可以在数据校验中显示：预期值、实际值、校验结果，这些显示的数据就是通过上面编写的脚本实现的；相反，如果校验失败，上面的脚本就会走第二个分支，同时还会有Exception抛出，用例在执行时如果脚本有异常语句运行了组件就会失败，也就是下图中会看到组件后面不是打钩而是一个红叉，同样双击该组件就可以看到“数据校验”中显示的预期值、实际值、校验结果，就可以通过看到显示的预期值和实际值判断为什么校验失败了：


8.3.6 如何迁移TC数据 - TestCenter5.5帮助文档

8.3.6 如何迁移TC数据

一、 数据迁移准备工作

l 准备TestCenter迁移文件，迁移文件包括TC程序和数据库文件。

l 准备部署服务的环境。

二、 迁移服务器

1) 迁移服务器拷贝TC程序

压缩迁移服务器TC安装目录里下tomcat7文件夹（D:\Program Files (x86)\Spasvo\TestCenter\tomcat7.1）并拷贝至新的部署服务器。

2) 2.2 迁移服务器拷贝数据库文件

l 停止MySql服务，在windows服务中停止spasvoDBServer服务，确认服务中可执行文件路径为TC安装目录里DBSVR\bin的路径，确认服务状态为已停止。

l 压缩tc安装目录里DBSVR文件夹并拷贝至新的部署服务器。

三、 部署服务器

1) 配置环境

a) 如果为老版本安装包，要安装对应jdk，并配置好JAVA_HOME,path,classpath 环境变量，如果为新的安装包则不需要。

b) 部署服务器上建议不要有mysql服务，如果有mysql服务则先停止这些mysql服务，并且已有mysql服务注册的名称不能为spasvoDBServer。

c) 通过TestCenter安装包安装一个新的tc。

d) 通过安装版的tc申请属于本机的license文件

先启动安装版tc

再在开始菜单中打开TCLicese页面，生成的.req文件用于申请lic。

2) 迁移数据

a) 将从迁移服务器拷贝过来的tomcat7.0文件夹放到部署服务器的TC安装目录中。

b） 停止spasvoDBServer服务，先删除原安装包中的DBSVR文件夹，再将迁移的DBSVR 文件夹拷贝进来，可修改my.ini配置文件，如下图所示。其中MySQL端口号如果冲突，则修改为其他端口号，如果不冲突可以使用默认的3306端口。basedir和datadir参数根据实际情况配置。

c) 启动spasvoDBServer服务

d) 查看TestCenter\tomcat7.0\webapps\TestLab\WEB-INF文件夹中的hibernate.cfg.xml文件，确保图中的ip和port配置正确，IP为TC数据库所在服务器的IP地址，port为MySQL数据库my.ini文件中配置的端口号。

e) 在取得属于本机的lic文件，lic文件通过发邮件给support@spasvo.com申请取得，并导入许可证，具体操作步骤如下：

l 申请license

先点击启动TestCenter图标，打开Tomcat服务器。然后在服务器上访问http://localhost:8080/TestLab/Admin.html登录管理员账号（admin 111111），点击许可证，选择申请许可证，弹出申请许可证对话框，选择需要申请的类型，使用的时长，以及同时在线人数，点击确定按钮，即可导出license。若系统已过期不能登陆后台，可以直接访问

http://localhost:8080/TCLicence/TCLicence.html进行license申请。

将导出的testcentet.req文件通过e-mail发送到 support@spasvo.com邮箱申请

l 导入licence

与申请lic时一致，进入到许可证页面，选择导入许可证，将回复的lic文件导入到系统内，导入成功后，重新启动Tomact，即可成功使用系统。

通过 TestCenter\tomcat7.0\bin内的TestCenter.bat启动tc服务即可。

验证在前台页面能够正常使用tc。

至此，所有迁移步骤完成。

四、 迁移验证

迁移验证：组件、需求、用例总数是否一致，是否可以批量自动执行


8.4 其他 - TestCenter5.5帮助文档

8.4 其他


8.4.1 当前登录账户没达到Licence上限，登录时却提示Licence人数已满 - TestCenter5.5帮助文档

8.4.1 当前登录账户没达到Licence上限，登录时却提示Licence人数已满

这种情况是用户上次登录未正常退出，只是关闭了登录页面，造成的，正常退出应先注销。进入后台，在登录历史记录里面查看当前在线用户，并删除需要登录的用户就可以登录了。


8.4.2 TC调用脚本，第一个执行成功，后面的失败 - TestCenter5.5帮助文档

8.4.2 TC调用脚本，第一个执行成功，后面的失败

原因：

1. 空闲时间太长

2. AR中动态数据库文件，xml文件以及license跟TestAgent是否一致。


8.4.3 本机需要装2个版本的TC或者装多个TC？ - TestCenter5.5帮助文档

8.4.3 本机需要装2个版本的TC或者装多个TC？

安装的时候不要安装MySql.安装目录设置到其他路径

由于新旧两个版本的数据库都叫testcenter所以应将新安装的TestCenter的数据库重命名

比如将新版本的TestCenter的数据库改为testcenter1

除更改第2条中的server.xml外还需要更改以下文件。

一． hibernate.cfg.xml

位于：

C:\Program Files\SpasvoSoft\TestCenter\tomcat5.5\webapps\TestLab\WEB-INF

红色部分以实际安装路径为准

1>第10行：

jdbc:mysql://localhost/testcenter?useUnicode=false&characterEncoding=gb2312

将testcenter改为testcenter1

workflow_hiber.cfg.xml

位于：

C:\ProgramFiles\SpasvoSoft\TestCenter\tomcat5.5\webapps\TestLab\WEB-INF

红色部分以实际安装路径为准

1> 第15行：

jdbc:mysql://localhost/testcenter?useUnicode=false&characterEncoding=gb2312

将testcenter改为testcenter1

一． db.properties

位于：

C:\Program Files\SpasvoSoft\TestCenter\tomcat5.5\webapps\TestLab\WEB-INF\

testcenterConfig

红色部分以实际安装路径为准

1> 第8行：

url=jdbc:mysql://localhost/testcenter?useUnicode=false&characterEncoding=gb2312

将testcenter改为testcenter1

二． 还要更改TC根目录下testcnter.sql的一些东西。

1>第20、21行

DROP DATABASE IF EXISTS testcenter;

CREATE DATABASE IF NOT EXISTS testcenter CHARSET=gb2312;

改为

DROP DATABASE IF EXISTS testcenter1;

CREATE DATABASE IF NOT EXISTS testcenter1 CHARSET=gb2312;

2> 第24行

use testcenter;

改为

use testcenter1;

三． 更改好以后导入数据库脚本文件testcenter.sql.命令如下：

source C:\Program Files\SpasvoSoft\TestCenter\testcenter.sql

红色部分以实际路径为准。


8.4.4 同一个用户名称是否可以同时登录多个项目？ - TestCenter5.5帮助文档

8.4.4 同一个用户名称是否可以同时登录多个项目？

同一个用户名是可以在同时登陆多个项目的。


8.4.5 是否可以支持脱机提交？ - TestCenter5.5帮助文档

8.4.5 是否可以支持脱机提交？

除非您是在安装的TC的电脑上操做，如果在其他电脑上操作，您必须保证电脑是连接网络状态。


8.4.6 多台并行操作提交可以自动合并信息到一个项目里？ - TestCenter5.5帮助文档

8.4.6 多台并行操作提交可以自动合并信息到一个项目里？

这个需要改是看客户是要进行什么操作，如果输入同时在一个模块中建立，如果名称保持一致是只有一个能正常保存，其他均不能正常保存，如果是在同一个模块中修改信息，只要不是修改不要信息都可以正常提交。如果在一个项目中的不同模块，同时提交动作没有相互影响，都能正常添加。


8.4.7 哪些功能有自定义功能？ - TestCenter5.5帮助文档

8.4.7 哪些功能有自定义功能？

现在提供模块属性定制、缺陷属性定制、缺陷流程定制3个模块属性定制。


8.4.8 需求若太复杂如何简化？ - TestCenter5.5帮助文档

8.4.8 需求若太复杂如何简化？

首先分析，把需求分成多个组成模块，根据相互关联的关系首先剔除重复的或者无数据的需求信息，在可以和具体的需求分析人员讨论，


8.4.9 数据库是否有自动备份？ - TestCenter5.5帮助文档

8.4.9 数据库是否有自动备份？

数据库没有自动备份功能，如果需要备份，可以在后台的数据库管路中手动备份数据库信息。


8.4.10 TC可以和那些自动化测试工具连接 - TestCenter5.5帮助文档

8.4.10 TC可以和那些自动化测试工具连接

现在TC是可以直接和我们的自动化测试工具AutoRunner相连接的，如果客户使用其他工具可以告知可以定制，使客户的软件和我们的TC连接。


8.4.11 Admin账户密码怎么恢复 - TestCenter5.5帮助文档

8.4.11 Admin账户密码怎么恢复

1. 如果是刚装上，里面没什么重要的数据，可以直接卸载后重装。

2. 如果不想重装就只能到数据库里面修改密码了，但是密码是加密的，只能去替换密文，方法如下：

第一步：找到TC安装目录C:\Program Files\Spasvo\TestCenter下的testcenter.sql文件。

第二步：右键点击testcenter.sql进行编辑，打开testcenter.sql文件，搜索关键字admin。


8.4.12 在TCD中不能显示需求 - TestCenter5.5帮助文档

8.4.12 在TCD中不能显示需求

删除TestCenter\jre6\lib下面的access_briage.propties


8.4.13 TC需求报NaN - TestCenter5.5帮助文档

8.4.13 TC需求报NaN

打开tc安装路径，进入jre6文件下，搜索框中输入acc进行搜索，删除accesibility.properties文件即可。


8.4.14 TC在提交缺陷的时候，添加附件保存的时候没有反应 - TestCenter5.5帮助文档

8.4.14 TC在提交缺陷的时候，添加附件保存的时候没有反应

出现这种情况是因为浏览器造成的，TC最好使用IE浏览器来操作，版本最好为6~10。


8.4.15 test用户登录在添加测试集的时候提示用户名重复 - TestCenter5.5帮助文档

8.4.15 test用户登录在添加测试集的时候提示用户名重复

test用户是系统自带的测试用户，建议重新创建用户使用


8.4.16 TC的登陆历史是否能够清空 - TestCenter5.5帮助文档

8.4.16 TC的登陆历史是否能够清空

这个是考虑到管理者可以方便查看各个用户的登陆信息，在界面上不能删除，可以在数据库中删除，但是不建议这么做，数据库中信息最好不要随意改动。


8.4.17 用TC时，部分模块界面显示错误 - TestCenter5.5帮助文档

8.4.17 用TC时，部分模块界面显示错误

原本安装有旧版本TC,之后安装新版本时，没有卸载旧版本而是直接覆盖安装，部分文件没有更新，导致界面显示错误，重新安装后问题解决


8.4.18 使用TC时提示域名无法访问 - TestCenter5.5帮助文档

8.4.18 使用TC时提示域名无法访问

用户安装TC的桌面快捷方式被杀毒软件拦截，导致快捷方式指向无效，重新生成快捷方式就行；或者可以在浏览器内直接输入网址即可。


8.4.19 TC用例分配的界面缺陷提交按钮无法使用 - TestCenter5.5帮助文档

8.4.19 TC用例分配的界面缺陷提交按钮无法使用

没有提交执行错误的用例，无法使用


8.4.20 权限分配失败 - TestCenter5.5帮助文档

8.4.20 权限分配失败

默认权限里面有重复的角色，删除多余的角色就可以了


8.4.21 将TC迁移至另一台电脑 - TestCenter5.5帮助文档

8.4.21 将TC迁移至另一台电脑

拷贝安装文件和申请lic

将TestCenter_WEB_5.5.1.0.exe安装程序（或泽众客户定制的testcenter安装程序）在B机器上安装，如果需要申请lic就按照TestCenter的lic正常申请流程将B机器的testcenter.req文件导出并发给上海泽众软件技术支持邮箱support@spasvo.com进行申请

在申请lic时需要和相关的销售沟通申请的流程，因为涉及到更换服务器，或直接提交给销售进行申请期限确认

TC主程序覆盖

将A机器上例：D:\Program Files (x86)\Spasvo\TestCenter\tomcat5.5\webapps路径下的TestLab拷贝，并把B机器上相同路径下的TestLab文件夹替换或覆盖

数据库迁移

将A机器上例：D:\Program Files (x86)\Spasvo\TestCenter\DBSVR路径下的data文件夹（即TC数据库数据）拷贝，并把B机器上相同路径下的data文件夹替换或覆盖

重启B机器的Tomcat服务器，即可正常使用


8.4.22 服务器上装有IIS或weblogic会不会与tomcat冲突？ - TestCenter5.5帮助文档

8.4.22 服务器上装有IIS或weblogic会不会与tomcat冲突？

不冲突，3个端口不一样tomcat是8080，IIS是80.weblogic是7001。


8.4.23 输入输出参数的理解？ - TestCenter5.5帮助文档

8.4.23 输入输出参数的理解？

输入参数和输出参数可以在定义测试用例的时候进行设置。也可以在制作测试集的时候进行设置。输入参数表示向被测系统输入的一个参数值，而输出参数表示系统的反馈值。在数值传递中，输入和输出参数都可以作为数据源操作，但目标源只能是输入参数。也就是说，一个测试用例的输入和输出都可以作为数据传递给另一个测试用例的输入参数，但不能传递给这个测试用例的输出参数。


8.4.24 怎样进行测试用例复用？ - TestCenter5.5帮助文档

8.4.24 怎样进行测试用例复用？

TestCenter中一个测试用例可以直接被多个测试集所包含，形成了复用的基础，同时一个测试用例可以关联多个业务组件。而在操作测试集时，可以令测试集包含测试集，举例说明：前一次测试，制作了一个测试集，其中包含了1-50的测试用例（假设有100个测试用例编号为1-100），那么这一次测试如果需要制作一个包含1-100的测试用例的测试集时，我们只需要做一个测试集，包含51-100，然后将上一次包含1-50的这个测试集包含进来，就构成了1-100的测试用例的测试集。


8.4.25 TC新增计划失败,Tomcat报错如下？ - TestCenter5.5帮助文档

8.4.25 TC新增计划失败,Tomcat报错如下？

解决办法：数据库版本与数据库驱动不一致，查看使用的数据库版本，并更换系统内的数据库驱动为对应的版本


8.4.26 IE11,TC输入框使用backspace会导致页面后退 - TestCenter5.5帮助文档

8.4.26 IE11,TC输入框使用backspace会导致页面后退

在IE中，backspace键包含两个含义回退跟清除。如果当时页面上没有聚焦在输入框中，backspace的行为就是回退到上一个页面，如果当时聚焦在输入框中，backspace的行为就是删除输入框里的值了。


8.5 TC与AR联跑常见问题 - TestCenter5.5帮助文档

8.5 TC与AR联跑常见问题


8.5.1 如果TC和AR跑自动化的时候遇到以下情况 - TestCenter5.5帮助文档

8.5.1 如果TC和AR跑自动化的时候遇到以下情况

1.每执行一条测试用例，就会报出网络异常错误,点确定后还能继续执行

2.在TestAgent中Resources下无法读取到脚本的信息，即加载不到AR脚本信息记录

3.在TestAgent控制台中会有错误提示：无法访问到AR脚本信息

解决方案：

1.先确定网络是否存在多个IP，如果有，禁用不需要的网络

2.如果网络没有问题，只需重启TestAgent即可


8.5.2 如果AR报-11错误该怎么解决？ - TestCenter5.5帮助文档

8.5.2 如果AR报-11错误该怎么解决？

-11 System32日期不匹配（在C:\Windows\System32下找到loadprj.cwd文件删掉，然后重装下）


8.5.3 怎样与自动化测试脚本关联？ - TestCenter5.5帮助文档

8.5.3 怎样与自动化测试脚本关联？

TestCenter中可以使用业务组件对自动化测试脚本进行关联，但预先需要进行设置，对于泽众公司的Terminal AutoRunner和Application AutoRunner，可以非常方便地进行调用。Terminal AutoRunner在产品安装时就已经预先设置好了路径，TestCenter会自动去查询测试工具的脚本位置。而对于Application AutoRunner，需要在安装目录下的tc_webar.bsh中进行设置，其中的第一句scriptpath="D:/test";即为设置路径，该句表示路径为D盘目录下的test文件夹下的所有脚本。